package/libgtk3: enable gobject-introspection support
authorAdam Duskett <Aduskett@gmail.com>
Wed, 1 Apr 2020 00:21:26 +0000 (17:21 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:35:21 +0000 (22:35 +0200)
If gobject-introspection is selected, add the gobject-introspection package to
the dependency list and set the conf opt --enable-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libgtk3/libgtk3.mk

index 7df4426fa627c8a0411a92fca3134db8473c9e4e..dbb975dbfdbb5b8255098c3ce94e95a9889985b0 100644 (file)
@@ -20,7 +20,6 @@ LIBGTK3_CONF_ENV = \
 
 LIBGTK3_CONF_OPTS = \
        --disable-glibtest \
-       --disable-introspection \
        --enable-explicit-deps=no
 HOST_LIBGTK3_CONF_OPTS = --disable-introspection
 
@@ -43,6 +42,13 @@ else
 LIBGTK3_CONF_OPTS += --disable-x11-backend
 endif
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+LIBGTK3_CONF_OPTS += --enable-introspection
+LIBGTK3_DEPENDENCIES += gobject-introspection
+else
+LIBGTK3_CONF_OPTS += --disable-introspection
+endif
+
 ifeq ($(BR2_PACKAGE_LIBGTK3_WAYLAND),y)
 LIBGTK3_DEPENDENCIES += wayland wayland-protocols libxkbcommon
 LIBGTK3_CONF_OPTS += --enable-wayland-backend