package/brltty: disable features and add optional dependencies
authorMario Lang <mlang@blind.guru>
Mon, 18 Dec 2017 09:51:43 +0000 (10:51 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 18 Dec 2017 14:55:21 +0000 (15:55 +0100)
* --without-midi-package should fix a number of autobuild failures.
* Disable a number of speech drivers to avoid build failures
  if they are installed on the host.
* Optional dependency on espeak and flite fixes builds where
  espeak or flite are installed on the host.

Fixes:

  http://autobuild.buildroot.net/results/0c4f557c2ad276b1ed065119532af37c0af5f014
  http://autobuild.buildroot.net/results/ea82b7c7732821368746ddddb5d529e97c9b6c16

Signed-off-by: Mario Lang <mlang@blind.guru>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/brltty/brltty.mk

index 5ce068416891de53782946e2f5328ec71b7b6479..7214f10fa09e9a28bfcd840746284bdd55b50f79 100644 (file)
@@ -18,7 +18,10 @@ BRLTTY_CONF_OPTS = \
        --disable-lisp-bindings \
        --disable-ocaml-bindings \
        --disable-python-bindings \
-       --disable-tcl-bindings
+       --disable-tcl-bindings \
+       --without-midi-package \
+       --without-mikropuhe --without-speechd --without-swift \
+       --without-theta --without-viavoice
 
 ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS),y)
 BRLTTY_DEPENDENCIES += bluez5_utils
@@ -27,6 +30,20 @@ else
 BRLTTY_CONF_OPTS += --without-bluetooth-package
 endif
 
+ifeq ($(BR2_PACKAGE_ESPEAK),y)
+BRLTTY_DEPENDENCIES += espeak
+BRLTTY_CONF_OPTS += --with-espeak=$(TARGET_DIR)/usr
+else
+BRLTTY_CONF_OPTS += --without-espeak
+endif
+
+ifeq ($(BR2_PACKAGE_FLITE),y)
+BRLTTY_DEPENDENCIES += flite
+BRLTTY_CONF_OPTS += --with-flite=$(STAGING_DIR)/usr
+else
+BRLTTY_CONF_OPTS += --without-flite
+endif
+
 ifeq ($(BR2_PACKAGE_ICU),y)
 BRLTTY_DEPENDENCIES += icu
 BRLTTY_CONF_OPTS += --enable-icu