- we need to pass ARCH to the kernel; The kernel does not have a table to
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 9 Oct 2006 16:13:12 +0000 (16:13 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 9 Oct 2006 16:13:12 +0000 (16:13 -0000)
  normalize the passed in ARCH, from the looks, so we have to normalize it manually. XXX: FIXME upstream via a simple shell script like the cc-checks!
  FIXME: flesh this out..

toolchain/kernel-headers/kernel-headers.mk

index f999ebfd4a2aae8cfe3eb2c34a4fd6934189b61f..b49af2fb606adc0c49c743c22e4abf65121fa446 100644 (file)
@@ -128,12 +128,15 @@ endif
 
 ifeq ($(LINUX_HEADERS_IS_KERNEL),y)
 # full kernel tarball >= 2.6.18
+
+KERNEL_ARCH:=$(shell $(SHELL) -c 'if test "$(ARCH)" = "i486" -o "$(ARCH)" = "i586"; then echo i386; else echo $(ARCH); fi')
+
 $(LINUX_HEADERS_UNPACK_DIR)/.patched: $(LINUX_HEADERS_UNPACK_DIR)/.unpacked
        toolchain/patch-kernel.sh $(LINUX_HEADERS_UNPACK_DIR) toolchain/kernel-headers linux-$(LINUX_HEADERS_VERSION)\*.patch
 
 $(LINUX_HEADERS_DIR)/.configured: $(LINUX_HEADERS_UNPACK_DIR)/.patched
        (cd $(LINUX_HEADERS_UNPACK_DIR) ; \
-        $(MAKE) INSTALL_HDR_PATH=$(LINUX_HEADERS_DIR) headers_install)
+        $(MAKE) ARCH=$(KERNEL_ARCH) INSTALL_HDR_PATH=$(LINUX_HEADERS_DIR) headers_install)
        touch $(LINUX_HEADERS_DIR)/.configured
 else
 # the sanitized kernel-headers