package/wine: update optional dependencies for 5.12
authorAndré Hentschel <nerv@dawncrow.de>
Fri, 30 Oct 2020 14:25:29 +0000 (15:25 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 31 Oct 2020 15:04:23 +0000 (16:04 +0100)
wine was bumped to 5.12 in commit
6daf15db41c1d9c97a4fe7d6233a2cbe06f88db1, but a few changes in
optional dependencies were not taken into account:

 - A new optional dependency on libusb exists

 - The option name to use libv4l has been changed

Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wine/wine.mk

index 7d7b22a1374375e2c6feb10f60d4ceab7db0612c..7eafe9b06dcaeed247d0a8551149331d8240363e 100644 (file)
@@ -145,11 +145,18 @@ else
 WINE_CONF_OPTS += --without-png
 endif
 
+ifeq ($(BR2_PACKAGE_LIBUSB),y)
+WINE_CONF_OPTS += --with-usb
+WINE_DEPENDENCIES += libusb
+else
+WINE_CONF_OPTS += --without-usb
+endif
+
 ifeq ($(BR2_PACKAGE_LIBV4L),y)
-WINE_CONF_OPTS += --with-v4l
+WINE_CONF_OPTS += --with-v4l2
 WINE_DEPENDENCIES += libv4l
 else
-WINE_CONF_OPTS += --without-v4l
+WINE_CONF_OPTS += --without-v4l2
 endif
 
 ifeq ($(BR2_PACKAGE_LIBXML2),y)
@@ -386,7 +393,8 @@ HOST_WINE_CONF_OPTS += \
        --without-sane \
        --without-sdl \
        --without-tiff \
-       --without-v4l \
+       --without-usb \
+       --without-v4l2 \
        --without-vkd3d \
        --without-vulkan \
        --without-x \