customize: fix copy paths
authorLuca Ceresoli <luca@lucaceresoli.net>
Wed, 5 May 2010 22:16:59 +0000 (00:16 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 6 May 2010 21:27:58 +0000 (23:27 +0200)
Closes #849, #1135

customize.mk used to copy files with a wrong command, resulting in one
directory level in excess. For example, source/etc/myfile would have
produced /etc/etc/myfile in the target filesystem instead of /etc/myfile.

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/customize/customize.mk

diff --git a/CHANGES b/CHANGES
index 46939f0ea93f790aa06db2df265b6253691a2558..10ca888e716163e6ac2b0024efcce41c6efb74e1 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -2,13 +2,15 @@
 
        Fixes all over the tree.
 
-       Updated/fixed packages: hal, mplayer, pciutils,
+       Updated/fixed packages: customize, hal, mplayer, pciutils,
        xdriver_xf86-video-openchrome, usb_modeswitch, usbutils,
        wpa_supplicant
 
        Issues resolved (http://bugs.uclibc.org):
 
+       #849: "customize" package copies files to wrong place in target tree
        #985: Bump usb_modeswitch package to 1.1.0
+       #1135: Package customize. Wrong copying
        #1525: Package hal deletes a whole <target>/etc/rc.d directory
        #1699: Fix usbutils dependencies and bump
        #1705: Fix pciutils broken cross compiling
index 780e42b00b545a103963d4cf6f2a79cf8c1f2275..d2b851872517bfdd97024c0edd1625c5b278974e 100644 (file)
@@ -11,7 +11,7 @@ $(BUILD_DIR)/.customize:
         /bin/ls -d * > $(BUILD_DIR)/series || \
         touch $(BUILD_DIR)/series )
        for f in `cat $(BUILD_DIR)/series`; do \
-               cp -af $(CUST_DIR)/$$f $(TARGET_DIR)/$$f; \
+               cp -af $(CUST_DIR)/$$f $(TARGET_DIR); \
        done
        rm -f $(BUILD_DIR)/series
        touch $@