toolchain-external: bump Linaro ARM toolchains to 2013.04 and 2013.05
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 8 Jun 2013 09:14:15 +0000 (11:14 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 10 Jun 2013 22:01:36 +0000 (00:01 +0200)
We add support for Linaro 2013.04 and Linaro 2013.05 and remove
support for Linaro 2013.01 and Linaro 2013.02.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 37c5648582a70cfbc1e37872ac670da67244dee8..6a58e0f216c07c5ee367c7b601fca358dbed368b 100644 (file)
@@ -3,8 +3,8 @@ if BR2_TOOLCHAIN_EXTERNAL
 choice
        prompt "Toolchain"
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03
-       bool "Linaro 2013.03"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
+       bool "Linaro 2013.05"
        depends on BR2_arm
        depends on BR2_cortex_a5 || BR2_cortex_a8 || BR2_cortex_a9 || BR2_cortex_a15
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -14,16 +14,16 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2013.03 (based on gcc 4.7), Linaro GDB 2012.12 (based on
-         GDB 7.5), eglibc 2.15. It generates code that runs on all
+         GCC 2013.05 (based on gcc 4.8), Linaro GDB 2013.05 (based on
+         GDB 7.6), eglibc 2.15. It generates code that runs on all
          Cortex-A profile devices, but tuned for the Cortex-A9. The
          code generated is Thumb 2, with the hard floating point
          calling convention, and uses the VFPv3-D16 FPU instructions.
 
          To use this toolchain, you must disable soft float usage.
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_02
-       bool "Linaro 2013.02"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
+       bool "Linaro 2013.04"
        depends on BR2_arm
        depends on BR2_cortex_a5 || BR2_cortex_a8 || BR2_cortex_a9 || BR2_cortex_a15
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -33,7 +33,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_02
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2013.02 (based on gcc 4.7), Linaro GDB 2012.12 (based on
+         GCC 2013.04 (based on gcc 4.7), Linaro GDB 2012.12 (based on
          GDB 7.5), eglibc 2.15. It generates code that runs on all
          Cortex-A profile devices, but tuned for the Cortex-A9. The
          code generated is Thumb 2, with the hard floating point
@@ -41,8 +41,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_02
 
          To use this toolchain, you must disable soft float usage.
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_01
-       bool "Linaro 2013.01"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03
+       bool "Linaro 2013.03"
        depends on BR2_arm
        depends on BR2_cortex_a5 || BR2_cortex_a8 || BR2_cortex_a9 || BR2_cortex_a15
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -52,7 +52,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_01
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2013.01 (based on gcc 4.7), Linaro GDB 2012.12 (based on
+         GCC 2013.03 (based on gcc 4.7), Linaro GDB 2012.12 (based on
          GDB 7.5), eglibc 2.15. It generates code that runs on all
          Cortex-A profile devices, but tuned for the Cortex-A9. The
          code generated is Thumb 2, with the hard floating point
@@ -741,9 +741,9 @@ config BR2_TOOLCHAIN_EXTERNAL_CUSTOM_PREFIX
 
 config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        string
+       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
+       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03
-       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_02
-       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_01
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201305
index 218ef07496ee59baae2724ee5924a4a8fb6fbe15..93aec83cc5d13a17b6570065c06629d0167db938 100644 (file)
@@ -200,15 +200,15 @@ TOOLCHAIN_EXTERNAL_SOURCE=arm-2012.03-57-arm-none-linux-gnueabi-i686-pc-linux-gn
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201305),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/arm-none-linux-gnueabi/
 TOOLCHAIN_EXTERNAL_SOURCE=arm-2013.05-24-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_01),y)
-TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2013.01/+download/
-TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2013.01-20130125_linux.tar.bz2
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_02),y)
-TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.02/components/toolchain/binaries/
-TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2013.02-01-20130221_linux.tar.xz
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03),y)
 TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.03/components/toolchain/binaries/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2013.03-20130313_linux.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04),y)
+TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.04/components/toolchain/binaries/
+TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2013.04-20130415_linux.tar.xz
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05),y)
+TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.05/components/toolchain/binaries/
+TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.8-2013.05_linux.tar.xz
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/mips-linux-gnu/
 TOOLCHAIN_EXTERNAL_SOURCE=mips-2012.03-63-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2