Makefile: Fix the generation of locales
authortbultel <tbultel@basystemes.fr>
Fri, 20 Sep 2013 08:35:46 +0000 (10:35 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 20 Sep 2013 08:48:44 +0000 (10:48 +0200)
The -s option is only mandatory for the charmap,
else the filename is always empty and nothing
is generated.

Signed-off-by: Thierry Bultel <thierry.bultel@wanadoo.fr>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 6ef0edc2bb2e8c319184b634b38ffa59c1834e50..71d94ad8c94bb7393f62ea7613d1a4b98d11d8f7 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -554,7 +554,7 @@ ifneq ($(GENERATE_LOCALE),)
 target-generatelocales: host-localedef
        $(Q)mkdir -p $(TARGET_DIR)/usr/lib/locale/
        $(Q)for locale in $(GENERATE_LOCALE) ; do \
-               inputfile=`echo $${locale} | cut -f1 -d'.' -s` ; \
+               inputfile=`echo $${locale} | cut -f1 -d'.'` ; \
                charmap=`echo $${locale} | cut -f2 -d'.' -s` ; \
                if test -z "$${charmap}" ; then \
                        charmap="UTF-8" ; \