vtun: fix gcc5 build
authorBaruch Siach <baruch@tkos.co.il>
Thu, 1 Oct 2015 22:06:31 +0000 (01:06 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 2 Oct 2015 13:46:52 +0000 (15:46 +0200)
Add -std=gnu89 to CFLAGS to keep pre gcc5 inline function symbols visibility
rules.

Fixes:
http://autobuild.buildroot.net/results/a7e/a7e684174b90a852318a7a8bf41c4f477d159d56/
http://autobuild.buildroot.net/results/ab0/ab01f8e0467e85322c63b81bb7e84fd251e5d556/
http://autobuild.buildroot.net/results/117/117a68bf648b050dabed8088d1165c1d7d9301f0/

and more.

[Peter: add a comment explaining why]
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/vtun/vtun.mk

index 2b64ab9efc6966a095df08269e43bfa28a7d98d8..2a3f5481a6341cd79331bbcacc119fef8f88be68 100644 (file)
@@ -14,4 +14,7 @@ VTUN_CONF_OPTS = \
        --with-lzo-headers=$(STAGING_DIR)/usr/include/lzo \
        --with-lzo-lib=$(STAGING_DIR)/usr/lib
 
+# Assumes old-style gcc inline symbol visibility rules
+VTUN_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=gnu89"
+
 $(eval $(autotools-package))