sysklogd: override SKFLAGS with TARGET_CFLAGS
authorRomain Naour <romain.naour@gmail.com>
Sat, 20 Feb 2016 11:28:50 +0000 (12:28 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 20 Feb 2016 20:22:31 +0000 (21:22 +0100)
TARGET_CFLAGS is not taken into account since SKFLAGS is used as CFLAGS.
We need to override SKFLAGS with TARGET_CFLAGS but keep -DSYSV which was
present in SKFLAGS.

Improve the previous fix introduced by
8e3a5c13546451c0c6ceb8bc64e4397ceed14aca.

Fixes:
http://autobuild.buildroot.net/results/2fb/2fb94ecfdc32761a09da35e6fcbdd512847ec911

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Reported-by: Peter Korsgaard <peter@korsgaard.com>
Cc: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sysklogd/sysklogd.mk

index 9e315bcdf316eb6c92bba8ccd7d7ff3b711bb7a2..49997d4f23501cd1a3eaae56b48cfd01b7c65920 100644 (file)
@@ -14,16 +14,10 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 SYSKLOGD_DEPENDENCIES = busybox
 endif
 
-# CS PowerPC 2012.03 triggers compiler bug.
-ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC_E500V2),y)
-define SYSKLOGD_WORKAROUND_COMPILER_BUG
-       $(SED) 's/-O3/-O2/' $(@D)/Makefile
-endef
-SYSKLOGD_POST_PATCH_HOOKS = SYSKLOGD_WORKAROUND_COMPILER_BUG
-endif
-
+# Override SKFLAGS which is used as CFLAGS.
 define SYSKLOGD_BUILD_CMDS
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) SKFLAGS="$(TARGET_CFLAGS) -DSYSV" \
+               -C $(@D)
 endef
 
 define SYSKLOGD_INSTALL_TARGET_CMDS