c-icap-modules: new package
authorGuillaume GARDET <guillaume.gardet@oliseo.fr>
Tue, 18 Nov 2014 14:54:47 +0000 (15:54 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Jul 2015 22:14:05 +0000 (00:14 +0200)
[Thomas:
  - Do not pass custom CFLAGS and remove the hacks on the Makefile:
    since the c-icap-config script is now fixed, it returns correct
    values, and the hacks are no longer needed.
  - Add optional dependency on zlib and berkeleydb.
  - Explicitly disable clamav support.]

Signed-off-by: Guillaume GARDET <guillaume.gardet@oliseo.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/c-icap-modules/Config.in [new file with mode: 0644]
package/c-icap-modules/c-icap-modules.mk [new file with mode: 0644]

index e1b81a9d24d14e824c1c65bf01d3bada87504f82..9787521dec32c2b48ebcef2133237b1d59817b39 100644 (file)
@@ -1163,6 +1163,7 @@ menu "Networking applications"
        source "package/bridge-utils/Config.in"
        source "package/bwm-ng/Config.in"
        source "package/c-icap/Config.in"
+       source "package/c-icap-modules/Config.in"
        source "package/can-utils/Config.in"
        source "package/chrony/Config.in"
        source "package/civetweb/Config.in"
diff --git a/package/c-icap-modules/Config.in b/package/c-icap-modules/Config.in
new file mode 100644 (file)
index 0000000..616456b
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_C_ICAP_MODULES
+       bool "c-icap-modules"
+       depends on BR2_PACKAGE_C_ICAP
+       help
+         Additionals modules for c-icap server.
+
+         http://c-icap.sourceforge.net/
diff --git a/package/c-icap-modules/c-icap-modules.mk b/package/c-icap-modules/c-icap-modules.mk
new file mode 100644 (file)
index 0000000..27c57e1
--- /dev/null
@@ -0,0 +1,32 @@
+################################################################################
+#
+# c-icap-modules
+#
+################################################################################
+
+C_ICAP_MODULES_VERSION = 0.3.2
+C_ICAP_MODULES_SOURCE = c_icap_modules-$(C_ICAP_MODULES_VERSION).tar.gz
+C_ICAP_MODULES_SITE = http://downloads.sourceforge.net/c-icap/
+C_ICAP_MODULES_LICENCE = GPLv2+
+C_ICAP_MODULES_LICENCE_FILE = COPYING
+C_ICAP_MODULES_DEPENDENCIES = c-icap
+
+C_ICAP_MODULES_CONF_OPTS = \
+       --with-c-icap=$(STAGING_DIR)/usr/ \
+       --without-clamav
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+C_ICAP_MODULES_CONF_OPTS += --with-zlib
+C_ICAP_MODULES_DEPENDENCIES += zlib
+else
+C_ICAP_MODULES_CONF_OPTS += --without-zlib
+endif
+
+ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
+C_ICAP_MODULES_CONF_OPTS += --with-bdb
+C_ICAP_MODULES_DEPENDENCIES += berkeleydb
+else
+C_ICAP_MODULES_CONF_OPTS += --without-bdb
+endif
+
+$(eval $(autotools-package))