linux-firmware: add option to install QLogic FastLinQ 4xxxx firmware
authorGeoff Levand <geoff@infradead.org>
Thu, 26 Jul 2018 22:21:25 +0000 (22:21 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Jul 2018 20:19:58 +0000 (22:19 +0200)
Signed-off-by: Geoff Levand <geoff@infradead.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/linux-firmware/Config.in
package/linux-firmware/linux-firmware.mk

index 074bcc6c78d60269fda3b7903f7d4296501730d6..bb88afeec23bd049b1cd44f65e8d791e1d227d9c 100644 (file)
@@ -320,6 +320,12 @@ config BR2_PACKAGE_LINUX_FIRMWARE_CXGB4_T5
          Firmware files for Chelsio T5 1Gb and 10Gb ethernet cards
          (cxgb4)
 
+config BR2_PACKAGE_LINUX_FIRMWARE_QLOGIC_4X
+       bool "QLogic FastLinQ 4xxxx"
+       help
+         Firmware files for QLogic FastLinQ 4xxxx ethernet devices
+         (qede)
+
 config BR2_PACKAGE_LINUX_FIRMWARE_RTL_8169
        bool "Realtek 8169"
        help
index 8e53cacba4193c55edd0ebd2ffb1452819467d8c..c9866fd1bbf5136ecf7010f54ade9be2f9d1c33f 100644 (file)
@@ -381,6 +381,13 @@ LINUX_FIRMWARE_FILES += cxgb4/t5fw*.bin
 LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.chelsio_firmware
 endif
 
+ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_QLOGIC_4X),y)
+LINUX_FIRMWARE_FILES += \
+       qed/qed_init_values_zipped-8.33.11.0.bin
+# No license file; the license is in the file WHENCE
+# which is installed unconditionally
+endif
+
 ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_RTL_8169),y)
 LINUX_FIRMWARE_FILES += \
        rtl_nic/rtl8105e-1.fw \