package/tvheadend: add dbus as optional dependency
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 12 Oct 2015 20:39:30 +0000 (22:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 12 Oct 2015 21:44:20 +0000 (23:44 +0200)
Dbus is an optional dependency for tvheadend:
https://github.com/tvheadend/tvheadend/commit/9c7b6047d2e3040e14cdba89f46d8acb2a36a115

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tvheadend/tvheadend.mk

index 30598055b8dde960df2c805fd68bf78259efe88f..4ffb357a5ea292d5475b4eff5d367af9c69f7e5c 100644 (file)
@@ -18,6 +18,13 @@ ifeq ($(BR2_PACKAGE_AVAHI),y)
 TVHEADEND_DEPENDENCIES += avahi
 endif
 
+ifeq ($(BR2_PACKAGE_DBUS),y)
+TVHEADEND_DEPENDENCIES += dbus
+TVHEADEND_CONF_OPTS += --enable-dbus-1
+else
+TVHEADEND_CONF_OPTS += --disable-dbus-1
+endif
+
 ifeq ($(BR2_PACKAGE_FFMPEG),y)
 TVHEADEND_DEPENDENCIES += ffmpeg
 TVHEADEND_CONF_OPTS += --enable-libav