package/libqrtr-glib: new package
authorPetr Vorel <petr.vorel@gmail.com>
Thu, 25 Mar 2021 17:58:31 +0000 (18:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 28 Mar 2021 20:10:15 +0000 (22:10 +0200)
Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/libqrtr-glib/Config.in [new file with mode: 0644]
package/libqrtr-glib/libqrtr-glib.hash [new file with mode: 0644]
package/libqrtr-glib/libqrtr-glib.mk [new file with mode: 0644]

index ab05b352e2716a96d56f00e2982e7062f38375f0..44978286b1e4347125ae985a8962418fc069d539 100644 (file)
@@ -2127,6 +2127,7 @@ N:        Petr Vorel <petr.vorel@gmail.com>
 F:     package/ima-evm-utils/
 F:     package/iproute2/
 F:     package/iputils/
+F:     package/libqrtr-glib/
 F:     package/libtirpc/
 F:     package/linux-backports/
 F:     package/ltp-testsuite/
index ce8247f0aaf7f9d3269b33c0ae815f28e4e372f7..1269bc7b5125422420bc08fe21c7611cf50323cd 100644 (file)
@@ -1560,6 +1560,7 @@ menu "Hardware handling"
        source "package/libphidget/Config.in"
        source "package/libpri/Config.in"
        source "package/libqmi/Config.in"
+       source "package/libqrtr-glib/Config.in"
        source "package/libraw1394/Config.in"
        source "package/librtas/Config.in"
        source "package/librtlsdr/Config.in"
diff --git a/package/libqrtr-glib/Config.in b/package/libqrtr-glib/Config.in
new file mode 100644 (file)
index 0000000..ad4fd77
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_LIBQRTR_GLIB
+       bool "libqrtr-glib"
+       depends on BR2_USE_WCHAR # glib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
+       depends on BR2_USE_MMU # glib2
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_15 # da7653f0faab
+       select BR2_PACKAGE_LIBGLIB2
+       help
+         Qualcomm IPC Router protocol helper library.
+         Optional dependency for libqmi >= 1.28.0.
+
+         https://www.freedesktop.org/software/libqmi/libqrtr-glib/latest/
+
+comment "libqrtr-glib needs a toolchain w/ wchar, threads, headers >= 4.15"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
+               !BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_15
diff --git a/package/libqrtr-glib/libqrtr-glib.hash b/package/libqrtr-glib/libqrtr-glib.hash
new file mode 100644 (file)
index 0000000..e00dd0c
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LIB
+sha256  30d879b2ade6f8f461def3a677755db5c0238babf688d5c83c03b3e6abe35cee  libqrtr-glib-1.0.0.tar.xz
diff --git a/package/libqrtr-glib/libqrtr-glib.mk b/package/libqrtr-glib/libqrtr-glib.mk
new file mode 100644 (file)
index 0000000..b9fc5cf
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libqrtr-glib
+#
+################################################################################
+
+LIBQRTR_GLIB_VERSION = 1.0.0
+LIBQRTR_GLIB_SITE = http://www.freedesktop.org/software/libqmi
+LIBQRTR_GLIB_SOURCE = libqrtr-glib-$(LIBQRTR_GLIB_VERSION).tar.xz
+LIBQRTR_GLIB_LICENSE = LGPL-2.1+
+LIBQRTR_GLIB_LICENSE_FILES = COPYING.LIB
+LIBQRTR_GLIB_INSTALL_STAGING = YES
+LIBQRTR_GLIB_DEPENDENCIES = libglib2
+
+$(eval $(autotools-package))