package/ca-certificates: generate the bundle of certs
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 2 Apr 2015 23:09:06 +0000 (01:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Apr 2015 13:39:39 +0000 (15:39 +0200)
glib-networking wants to use the certificates bundle, not the individual
certificates.

Generating the bundle is usually done with update-ca-certificates, but
that does not support running out-of-tree.

Fortiunately, and as Gustavo put it, update-ca-certificates is jsut a
glorified 'cat'. It is supposed to be fed a config file stating which
certificate to add/remove to/from the bundle, otherwise nothing fancy
(Oh, yes, running hooks after updating the bundle).

Since we do not need any of this in Buidlroot, we jsut generate a bundle
with all certificates unconditionally.

Reported-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ca-certificates/ca-certificates.mk

index 271985a51705a70e1c6092cc0382ce09556c7eb7..8fe26c99cb1aaf69d4a6e8e268537a0ac48e8014 100644 (file)
@@ -25,9 +25,11 @@ define CA_CERTIFICATES_INSTALL_TARGET_CMDS
        rm -f  $(TARGET_DIR)/etc/ssl/certs/*
 
        # Create symlinks to certificates under /etc/ssl/certs
+       # and generate the bundle
        cd $(TARGET_DIR) ;\
        for i in `find usr/share/ca-certificates -name "*.crt"` ; do \
                ln -sf ../../../$$i etc/ssl/certs/`basename $${i} .crt`.pem ;\
+               cat $$i >>etc/ssl/certs/ca-certificates.crt ;\
        done
 
        # Create symlinks to the certificates by their hash values