parted: fix nommu build
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 30 Jun 2014 13:16:18 +0000 (10:16 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 30 Jun 2014 21:34:49 +0000 (23:34 +0200)
Add patch to accept uclinux in the tuple, and also disable dynamic libs
for static scenarios. Fixes:
http://autobuild.buildroot.net/results/d9a/d9a9baf0c1bfdb7f7d03ebed084a80ef3001c86d/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/parted/parted-002-configure.ac-uclinux-is-also-linux.patch [new file with mode: 0644]
package/parted/parted.mk

diff --git a/package/parted/parted-002-configure.ac-uclinux-is-also-linux.patch b/package/parted/parted-002-configure.ac-uclinux-is-also-linux.patch
new file mode 100644 (file)
index 0000000..b2119bc
--- /dev/null
@@ -0,0 +1,33 @@
+From b3958317c5ee2940e7024bec2e7f288b5a6a26c3 Mon Sep 17 00:00:00 2001
+From: Gustavo Zacarias <gustavo@zacarias.com.ar>
+Date: Mon, 30 Jun 2014 10:09:04 -0300
+Subject: [PATCH] configure.ac: uclinux is also linux
+
+uclinux is used in the tuple for some noMMU linux builds like Blackfin
+FLAT output, so accept it as linux too.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 436d0e2..50ad478 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -58,10 +58,10 @@ AM_SILENT_RULES([yes]) # make --enable-silent-rules the default.
+ AC_CANONICAL_HOST
+ case "$host_os" in
+-      linux*) OS=linux ;;
++      linux*|uclinux*) OS=linux ;;
+       gnu*)   OS=gnu ;;
+       beos*)  OS=beos ;;
+-      *)      AC_MSG_ERROR([Unknown or unsupported OS "$host_os".  Only "linux", "gnu" and "beos" are supported in this version of GNU Parted.]) ;;
++      *)      AC_MSG_ERROR([Unknown or unsupported OS "$host_os".  Only "linux", "uclinux", "gnu" and "beos" are supported in this version of GNU Parted.]) ;;
+ esac
+ AC_SUBST([OS])
+-- 
+1.8.5.5
+
index 15e37a8c63f9c3b447dc26beed576e30f8dc845d..fd82684a4fc8e8848a171640a03f1b99b66c25e3 100644 (file)
@@ -9,6 +9,8 @@ PARTED_SOURCE = parted-$(PARTED_VERSION).tar.xz
 PARTED_SITE = $(BR2_GNU_MIRROR)/parted
 PARTED_DEPENDENCIES = util-linux
 PARTED_INSTALL_STAGING = YES
+# For uclinux patch
+PARTED_AUTORECONF = YES
 PARTED_LICENSE = GPLv3+
 PARTED_LICENSE_FILES = COPYING
 
@@ -26,6 +28,10 @@ else
 PARTED_CONF_OPT += --disable-device-mapper
 endif
 
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+PARTED_CONF_OPT += --disable-dynamic-loading
+endif
+
 HOST_PARTED_DEPENDENCIES = host-util-linux
 HOST_PARTED_CONF_OPT += \
        --without-readline \