rsh-redone: new package for rsh/rlogin clients
authorMike Frysinger <vapier@gentoo.org>
Tue, 7 Dec 2010 21:03:56 +0000 (16:03 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 8 Dec 2010 22:32:13 +0000 (23:32 +0100)
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/Config.in
package/rsh-redone/Config.in [new file with mode: 0644]
package/rsh-redone/rsh-redone.mk [new file with mode: 0644]

diff --git a/CHANGES b/CHANGES
index 45585c18216c46673dfb46e29bf6f7ead0de9d60..47ba38d8bdbc464cf4f72375c396928727f24e6e 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -5,7 +5,7 @@
 
        Updated/fixed packages: cloop, m4, openssh, qt, xz
 
-       New packages: lsuio
+       New packages: lsuio, rsh-redone
 
        Issues resolved (http://bugs.uclibc.org):
 
index b026828553a41b8b350de6babef87022207d44ae..7c550cde37eb4eb634a3170a783f392df281f8d9 100644 (file)
@@ -416,6 +416,7 @@ source "package/rp-pppoe/Config.in"
 source "package/pptp-linux/Config.in"
 source "package/proftpd/Config.in"
 source "package/quagga/Config.in"
+source "package/rsh-redone/Config.in"
 source "package/rsync/Config.in"
 source "package/samba/Config.in"
 source "package/ser2net/Config.in"
diff --git a/package/rsh-redone/Config.in b/package/rsh-redone/Config.in
new file mode 100644 (file)
index 0000000..454bf30
--- /dev/null
@@ -0,0 +1,31 @@
+config BR2_PACKAGE_RSH_REDONE
+       bool "rsh-redone"
+       help
+         Rsh-redone is a reimplementation of the remote shell clients and
+         servers.  It is written from the ground up to avoid the bugs found
+         in the standard clients and servers.  It also fully supports IPv6.
+
+         http://packages.debian.org/source/sid/rsh-redone
+
+# this is incomplete in the source
+#config BR2_PACKAGE_RSH_REDONE_RCP
+#      bool "rcp"
+#      depends on BR2_PACKAGE_RSH_REDONE
+
+config BR2_PACKAGE_RSH_REDONE_RLOGIN
+       bool "rlogin"
+       depends on BR2_PACKAGE_RSH_REDONE
+
+# requires PAM
+#config BR2_PACKAGE_RSH_REDONE_RLOGIND
+#      bool "rlogind"
+#      depends on BR2_PACKAGE_RSH_REDONE
+
+config BR2_PACKAGE_RSH_REDONE_RSH
+       bool "rsh"
+       depends on BR2_PACKAGE_RSH_REDONE
+
+# requires PAM
+#config BR2_PACKAGE_RSH_REDONE_RSHD
+#      bool "rshd"
+#      depends on BR2_PACKAGE_RSH_REDONE
diff --git a/package/rsh-redone/rsh-redone.mk b/package/rsh-redone/rsh-redone.mk
new file mode 100644 (file)
index 0000000..6217cb1
--- /dev/null
@@ -0,0 +1,36 @@
+#############################################################
+#
+# rsh-redone
+#
+#############################################################
+
+RSH_REDONE_VERSION = 85
+RSH_REDONE_SOURCE = rsh-redone_$(RSH_REDONE_VERSION).orig.tar.gz
+RSH_REDONE_SITE = $(BR2_DEBIAN_MIRROR)/debian/pool/main/r/rsh-redone
+
+rsh-redone-bin-y =
+rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RCP) += rcp
+rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RLOGIN) += rlogin
+rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RSH) += rsh
+rsh-redone-sbin-y =
+rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RLOGIND) += rlogind
+rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RSHD) += rshd
+
+define RSH_REDONE_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) BIN="$(rsh-redone-bin-y)" SBIN="$(rsh-redone-sbin-y)"
+endef
+
+define RSH_REDONE_INSTALL_TARGET_CMDS
+       $(if $(rsh-redone-bin-y)$(rsh-redone-sbin-y),
+               $(RSH_REDONE_BUILD_CMDS) DESTDIR=$(TARGET_DIR) \
+                       $(if $(rsh-redone-bin-y),install-bin) \
+                       $(if $(rsh-redone-sbin-y),install-sbin))
+endef
+
+define RSH_REDONE_UNINSTALL_TARGET_CMDS
+       rm -f \
+               $(addprefix $(TARGET_DIR)/usr/bin/,$(rsh-redone-bin-y)) \
+               $(addprefix $(TARGET_DIR)/usr/sbin/,$(rsh-redone-sbin-y))
+endef
+
+$(eval $(call GENTARGETS,package,rsh-redone))