gst1-plugins-bad: add new Timed Text Markup Language (TTML) plugin
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Jul 2017 11:21:43 +0000 (13:21 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Jul 2017 11:31:41 +0000 (13:31 +0200)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 96ab12b5bc6d866f9bdae4fb9d810a01575008d4..67d3923c73eb183498c3f7049ca129816449c0c1 100644 (file)
@@ -547,6 +547,23 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_LIBMMS
 comment "libmms needs a toolchain w/ wchar, threads"
        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TTML
+       bool "ttml"
+       depends on BR2_USE_WCHAR # pango -> glib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # pango -> glib2
+       depends on BR2_INSTALL_LIBSTDCPP # pango -> freetype
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4 # pango -> harfbuzz
+       select BR2_PACKAGE_CAIRO
+       select BR2_PACKAGE_LIBXML2
+       select BR2_PACKAGE_PANGO
+       help
+         Timed Text Markup Language (TTML) subtitle plugin
+
+comment "ttml needs a toolchain w/ wchar, threads, C++"
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
+               !BR2_INSTALL_LIBSTDCPP
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MPEG2ENC
        bool "mpeg2enc"
        select BR2_PACKAGE_LIBMPEG2
index 6a66726c36a17109253f91c7c1f6fe28f37930cc..56e443c48049249293bc3a60f537decf0a20d42f 100644 (file)
@@ -636,6 +636,13 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-libmms
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TTML),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-ttml
+GST1_PLUGINS_BAD_DEPENDENCIES += cairo libxml2 pango
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-ttml
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MPEG2ENC),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-mpeg2enc
 GST1_PLUGINS_BAD_DEPENDENCIES += libmpeg2