imx-vpu: bump version to 5.4.38
authorGary Bisson <gary.bisson@boundarydevices.com>
Mon, 30 Jul 2018 13:01:41 +0000 (15:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 11 Aug 2018 17:36:09 +0000 (19:36 +0200)
No changelog provided by NXP.
Added COPYING hash value to track license changes.
Reworked the help text to specify which CPU has Chips&Media VPU.
Also removed the dependency on BR2_arm as
BR2_PACKAGE_FREESCALE_IMX_HAS_VPU is sufficient.

Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
[Thomas: add hash for EULA file.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/freescale-imx/imx-vpu/Config.in
package/freescale-imx/imx-vpu/imx-vpu.hash
package/freescale-imx/imx-vpu/imx-vpu.mk

index 779717f5ed96764b904f2e781316ab146801ffd1..dd3507eb9656b9cde5fede177f0c3b157dd4f0f5 100644 (file)
@@ -1,17 +1,14 @@
 comment "imx-vpu needs an i.MX platform with VPU support"
-       depends on BR2_arm
        depends on !BR2_PACKAGE_FREESCALE_IMX_HAS_VPU
 
 config BR2_PACKAGE_IMX_VPU
        bool "imx-vpu"
-       depends on BR2_arm # Only relevant for i.MX
        depends on BR2_PACKAGE_FREESCALE_IMX_HAS_VPU
        select BR2_PACKAGE_FIRMWARE_IMX
        help
-         Library of userspace helpers specific for the Freescale i.MX
-         platform. It wraps the kernel interfaces for the i.MX platform
-         Video Processing Unit (VPU) driver. It requires a kernel that
-         includes the i.MX specific headers to be built.
+         Library of userspace helpers specific for the NXP i.MX SoC
+         integrating a Chips&Media CODA Video Processing Unit (VPU)
+         such as the i.MX27/i.MX5x/i.MX6x.
 
-         This library is provided by Freescale as-is and doesn't have
-         an upstream.
+         This library is provided by NXP as-is and doesn't have an
+         upstream.
index 0ac0f3d0c2486179c2c827b5aca80ea78069a144..5fa93d8055d24f391b650faed4833c983b9c70de 100644 (file)
@@ -1,2 +1,4 @@
 # Locally computed
-sha256 ee265e88d17c7369bd9cb917e7cce035b8c7ee2ba4491645fdab9f382f54beb0  imx-vpu-5.4.37.bin
+sha256  34bed0ddf6c797f444bddfa5d5495adc751ff268b6431d8beb48129c89c9e47f  imx-vpu-5.4.38.bin
+sha256  78696664f7afe7f2b081c99af60082d6403fab935b1b10056ed41aec123ff7fa  COPYING
+sha256  fc93f26e4197b9240c327ce26ae6e02123f022423d4704c7b0448a37372cf2a2  EULA
index 2bcfe53eba0188c9cedb8a479b7237fb6915bb7e..e30237508efb5ad2884475c19ba53606edee5b9b 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-IMX_VPU_VERSION = 5.4.37
+IMX_VPU_VERSION = 5.4.38
 IMX_VPU_SITE = $(FREESCALE_IMX_SITE)
 IMX_VPU_SOURCE = imx-vpu-$(IMX_VPU_VERSION).bin