e2fsprogs: remove findfs option
authorJames Knight <james.knight@rockwellcollins.com>
Fri, 12 Feb 2016 16:40:05 +0000 (11:40 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 14 Feb 2016 21:02:26 +0000 (22:02 +0100)
The e2fsprogs package's findfs option provides no capabilities. When the
option is selected, a symbolic link is generated from findfs to e2label;
however, e2label will not handle findfs since the respective code is
explicitly disabled when `--disable-libblkid` is passed in. At this
time, the e2fsprogs package only supports findfs capabilities when
building its "private blkid library".

Note that the `--disable-libblkid` configuration argument must remain
to prevent conflicts with util-linux's libblkid and an e2fsprogs-
generated variant (see e1ffc2f791b336339909c90559b7db40b455f172).

Since e2fsprogs cannot provide findfs capabilities, the option is being
removed in this change. A following change will be introduced to include
util-linux's findfs utility.

Signed-off-by: James Knight <james.knight@rockwellcollins.com>
Cc: Zheng Yi <yzheng@techyauld.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/e2fsprogs/Config.in
package/e2fsprogs/e2fsprogs.mk

index 3677f867d5f53a807a52f9cbaa5c745b021aeb99..2fda9f8307da4162ab6f9dea942e59a4b8e7df4d 100644 (file)
@@ -145,6 +145,15 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.02"
 
+config BR2_PACKAGE_E2FSPROGS_FINDFS
+       bool "e2fsprogs findfs option has been removed"
+       select BR2_LEGACY
+       help
+         This option attempted to enable findfs capabilities from
+         e2fsprogs but has not worked since July 2015 (due to
+         packaging changes). One can use BusyBox's findfs support or
+         enable the BR2_PACKAGE_UTIL_LINUX_FINDFS option.
+
 config BR2_PACKAGE_OPENPOWERLINK_DEBUG_LEVEL
        bool "openpowerlink debug option has been removed"
        select BR2_LEGACY
index ad33983e83919c55ea1e1a0897b5bf51e67a6102..ac3eae71db703a8296c794f7e76c023166b3a898 100644 (file)
@@ -59,11 +59,6 @@ config BR2_PACKAGE_E2FSPROGS_FILEFRAG
        bool "filefrag"
        default y
 
-config BR2_PACKAGE_E2FSPROGS_FINDFS
-       bool "findfs"
-       default y
-       select BR2_PACKAGE_E2FSPROGS_E2LABEL
-
 config BR2_PACKAGE_E2FSPROGS_FSCK
        bool "fsck"
        default y
index 4b81b4473e6b8cf396bba0e809078329e02bc591..3de4cd48727f213c2f26d490d16373d61e833c2e 100644 (file)
@@ -74,7 +74,6 @@ E2FSPROGS_TXTTARGETS_ = \
        usr/sbin/mkfs.ext4dev \
        usr/sbin/fsck.ext[234] \
        usr/sbin/fsck.ext4dev \
-       usr/sbin/findfs \
        usr/sbin/tune2fs
 
 define E2FSPROGS_TARGET_REMOVE_UNNEEDED
@@ -137,14 +136,6 @@ ifeq ($(BR2_PACKAGE_E2FSPROGS_TUNE2FS),y)
 E2FSPROGS_POST_INSTALL_TARGET_HOOKS += E2FSPROGS_TARGET_TUNE2FS_SYMLINK
 endif
 
-define E2FSPROGS_TARGET_FINDFS_SYMLINK
-       ln -sf e2label $(TARGET_DIR)/usr/sbin/findfs
-endef
-
-ifeq ($(BR2_PACKAGE_E2FSPROGS_FINDFS),y)
-E2FSPROGS_POST_INSTALL_TARGET_HOOKS += E2FSPROGS_TARGET_FINDFS_SYMLINK
-endif
-
 # systemd really wants to have fsck in /sbin
 define E2FSPROGS_TARGET_FSCK_SYMLINK
        ln -sf ../usr/sbin/fsck $(TARGET_DIR)/sbin/fsck