squashfs: use kconfig to ensure atleast one compressor is selected
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 25 Feb 2011 20:27:40 +0000 (21:27 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 25 Feb 2011 20:27:40 +0000 (21:27 +0100)
Similar to how we do it for mpd now. This way, the selection is clearly
visible to the user, instead of the hidden selection we used to do in
the makefile.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/squashfs/Config.in
package/squashfs/squashfs.mk

index d28926e0f22c58d23282f0e1385ab2eea6262dc0..6730708620a9d6750603e073d02cf7121a031e36 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_SQUASHFS
        bool "squashfs"
        depends on BR2_LARGEFILE
+       select BR2_PACKAGE_SQUASHFS_GZIP if !(BR2_PACKAGE_SQUASHFS_LZMA || BR2_PACKAGE_SQUASHFS_LZO)
        help
          Tools to generate SquashFS filesystems.
 
index 7cbec32f1815a29d54966ce5f60d656bb4cf0edc..50e8964ca96120894c426f7d1ef355b3e2077041 100644 (file)
@@ -5,11 +5,6 @@ SQUASHFS_SITE=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/sq
 # no libattr/xz in BR
 SQUASHFS_MAKE_ARGS = XATTR_SUPPORT=0
 
-# we need atleast one compresser, so use gzip if none are enabled
-ifeq ($(BR2_PACKAGE_SQUASHFS_GZIP)$(BR2_PACKAGE_SQUASHFS_LZO)$(BR2_PACKAGE_SQUASHFS_LZMA),)
-BR2_PACKAGE_SQUASHFS_GZIP=y
-endif
-
 ifeq ($(BR2_PACKAGE_SQUASHFS_LZMA),y)
 SQUASHFS_DEPENDENCIES += xz
 SQUASHFS_MAKE_ARGS += XZ_SUPPORT=1 COMP_DEFAULT=lzma