package/kodi-pvr-vuplus: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 22 Jul 2015 20:30:50 +0000 (22:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 30 Jul 2015 07:37:45 +0000 (09:37 +0200)
[Thomas:
   - use a shorter file as the license file, client.h instead of client.cpp
   - do not pass -DCMAKE_MODULE_PATH, no longer needed.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/kodi-pvr-vuplus/Config.in [new file with mode: 0644]
package/kodi-pvr-vuplus/kodi-pvr-vuplus.mk [new file with mode: 0644]
package/kodi/Config.in

index 397b3ab3f2d0ed975ed782638e69e17e1d530bf5..9fd211e3f6af916ffa2e46a376d9422ab0df86a5 100644 (file)
@@ -124,6 +124,7 @@ config BR2_PACKAGE_KODI_PVR_ADDONS
        select BR2_PACKAGE_KODI_PVR_STALKER
        select BR2_PACKAGE_KODI_PVR_VBOX
        select BR2_PACKAGE_KODI_PVR_VDR_VNSI
+       select BR2_PACKAGE_KODI_PVR_VUPLUS
        help
          Kodi PVR addon was split into seperate modules
 
diff --git a/package/kodi-pvr-vuplus/Config.in b/package/kodi-pvr-vuplus/Config.in
new file mode 100644 (file)
index 0000000..a56c4ed
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_KODI_PVR_VUPLUS
+       bool "kodi-pvr-vuplus"
+       select BR2_PACKAGE_KODI_PLATFORM
+       help
+         VuPlus PVR client addon for Kodi
+
+         https://github.com/kodi-pvr/pvr.vuplus
diff --git a/package/kodi-pvr-vuplus/kodi-pvr-vuplus.mk b/package/kodi-pvr-vuplus/kodi-pvr-vuplus.mk
new file mode 100644 (file)
index 0000000..82569fd
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# kodi-pvr-vuplus
+#
+################################################################################
+
+KODI_PVR_VUPLUS_VERSION = 96115e9b8898ed6bde36874b43b2fba531cfef5c
+KODI_PVR_VUPLUS_SITE = $(call github,kodi-pvr,pvr.vuplus,$(KODI_PVR_VUPLUS_VERSION))
+KODI_PVR_VUPLUS_LICENSE = GPLv2+
+KODI_PVR_VUPLUS_LICENSE_FILES = src/client.h
+KODI_PVR_VUPLUS_DEPENDENCIES = kodi-platform
+
+$(eval $(cmake-package))
index 951532dec460f9a613957aea7ccf1dcdb55d233a..79e7e607c6289d8c567a8c8933bc4bba31f8841c 100644 (file)
@@ -272,6 +272,7 @@ menu "PVR addons"
        source "package/kodi-pvr-stalker/Config.in"
        source "package/kodi-pvr-vbox/Config.in"
        source "package/kodi-pvr-vdr-vnsi/Config.in"
+       source "package/kodi-pvr-vuplus/Config.in"
 endmenu
 
 endif # BR2_PACKAGE_KODI