pcre: always enable the 8-bits version
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 9 Mar 2013 04:40:35 +0000 (04:40 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 9 Mar 2013 20:06:46 +0000 (21:06 +0100)
Commit 7154798a461a8b2c (pcre: add support for 16 bits and 32 bits
variants), added in preparation to the introduction of the Qt5
packages, could break other packages that use pcre.

Even though by default the pcre 8 bits library is selected if no other
variant is selected, a randpackageconfig, or an user, could
potentially enable the 16 bits variant even if a package requires the
8 bits variant.

This has caused a number of build breakage on packages like ngrep,
cegui, nmap and others in the autobuilders.

In older to solve this, we simply unconditionally build the 8-bits
variant. Since each variant is only ~90k in size, it's probably not
worth the effort giving the possibility of building the 16 bits
variant only.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pcre/Config.in
package/pcre/pcre.mk

index 5d16e6d1bcdecf24b9788751ccda7b16289b69d2..dc92274102c8181f297fb152b24bdd514654223a 100644 (file)
@@ -1,20 +1,14 @@
 config BR2_PACKAGE_PCRE
        bool "pcre"
-       # Ensure at least the default 8-bit library is enabled.
-       select BR2_PACKAGE_PCRE_8 if \
-              (!BR2_PACKAGE_PCRE_16 && !BR2_PACKAGE_PCRE_32)
        help
-         Perl Compatible Regular Expressions
+         Perl Compatible Regular Expressions. By default, only the
+         8-bits libpcre is built. To get the 16-bits and/or 32-bits
+         variants libpcre16/libpcre32, use the package sub-options.
 
          http://www.pcre.org/
 
 if BR2_PACKAGE_PCRE
 
-config BR2_PACKAGE_PCRE_8
-       bool "8-bit pcre"
-       help
-         This option builds the 8-bits pcre library, i.e 'libpcre'
-
 config BR2_PACKAGE_PCRE_16
        bool "16-bit pcre"
        help
index b1339fbbc472615a149796a7583d624d98ca482f..745309fa88efe0ad7cb35202c9bc854b33367f6f 100644 (file)
@@ -16,7 +16,7 @@ ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
 PCRE_CONF_OPT = --disable-cpp
 endif
 
-PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_8),--enable-pcre8,--disable-pcre8)
+PCRE_CONF_OPT += --enable-pcre8
 PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_16),--enable-pcre16,--disable-pcre16)
 PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_32),--enable-pcre32,--disable-pcre32)