zeromq: add PGM/EPGM support
authorAlexander Lukichev <alexander.lukichev@gmail.com>
Sun, 3 Mar 2013 23:48:12 +0000 (23:48 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 17 Mar 2013 15:03:40 +0000 (16:03 +0100)
This adds support for Pragmatic General Multicast protocol on raw
IP (PGM, RFC 3208) or UDP frames (EPGM) for use as zeromq reliable
multicast transport. The library relies on openpgm package to
implement the protocol itself.

Signed-off-by: Alexander Lukichev <alexander.lukichev@gmail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/zeromq/Config.in
package/zeromq/zeromq.mk

index e1d3d520b8b7b335d66936cf29c56a49073ec0e7..b7dc8a63381ebb407b5d738a70c0295f160675c3 100644 (file)
@@ -23,3 +23,12 @@ config BR2_PACKAGE_ZEROMQ
          ØMQ is from iMatix and is LGPL open source.
 
          http://www.zeromq.org/
+
+config BR2_PACKAGE_ZEROMQ_PGM
+       bool "PGM/EPGM support"
+       depends on BR2_PACKAGE_ZEROMQ
+       select BR2_PACKAGE_OPENPGM
+       help
+         Add support for Pragmatic General Multicast protocol (RFC 3208)
+         implemented either over raw IP packets or UDP datagrams
+         (encapsulated PGM). This requires OpenPGM library.
index 2d0026d2d94ba0a7aeaf4555c8b0fa3196eaa4ab..ba585d9660284b037aae70cdbb019de2525611d6 100644 (file)
@@ -11,4 +11,9 @@ ZEROMQ_DEPENDENCIES = util-linux
 ZEROMQ_LICENSE = LGPLv3+ with exceptions
 ZEROMQ_LICENSE_FILES = COPYING COPYING.LESSER
 
+ifeq ($(BR2_PACKAGE_ZEROMQ_PGM),y)
+       ZEROMQ_DEPENDENCIES += host-pkgconf openpgm
+       ZEROMQ_CONF_OPT = --with-system-pgm
+endif
+
 $(eval $(autotools-package))