package/lvm2: drop BR2_PACKAGE_LVM2_APP_LIBRARY
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 17 May 2021 17:06:09 +0000 (19:06 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 17 May 2021 20:20:39 +0000 (22:20 +0200)
The application library (liblvm2app) has been dropped since version
2.03.00 and
https://github.com/lvmteam/lvm2/commit/0d22b58172808f050abeacdb5d6a7b7132b91a8c

It should be noted that lvm2 support must be dropped from udisks until
a bump to at least version 2.7.0 and
https://github.com/storaged-project/udisks/commit/4c0709a893be49a0db5b2839e4766621e2c1bb98

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr:
  - slightly expand help text for legacy BR2_PACKAGE_UDISKS_LVM2
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Config.in.legacy
package/lvm2/Config.in
package/lvm2/lvm2.mk
package/udisks/Config.in
package/udisks/udisks.mk

index 39a44f302659ff0d7f7b8af678a498ed017acd96..bc7cb8e32a2f1644b4f855b70b7455f0ab729ddb 100644 (file)
@@ -146,6 +146,20 @@ endif
 
 comment "Legacy options removed in 2021.05"
 
+config BR2_PACKAGE_UDISKS_LVM2
+       bool "udisks lvm2 support removed"
+       select BR2_LEGACY
+       help
+         The lvm2 support was removed because udisks < 2.7.0 still
+         depends on lvm2 application library, which was removed
+         in was removed lvm2.
+
+config BR2_PACKAGE_LVM2_APP_LIBRARY
+       bool "lvm2 application library removed"
+       select BR2_LEGACY
+       help
+         The lvm2 application library was removed upstream.
+
 config BR2_PACKAGE_LVM2_LVMETAD
        bool "lvm2 lvmetad removed"
        select BR2_LEGACY
index de5b972e999f9b3fb8a65fe2a2ad42e20fbcb425..f8bcdffb3833b923ee699e31d5c34090ef2442af 100644 (file)
@@ -36,17 +36,6 @@ config BR2_PACKAGE_LVM2_STANDARD_INSTALL
 comment "lvm2 standard install needs a glibc or uClibc toolchain"
        depends on BR2_TOOLCHAIN_USES_MUSL
 
-config BR2_PACKAGE_LVM2_APP_LIBRARY
-       bool "install application library"
-       # http://lists.busybox.net/pipermail/buildroot/2016-August/170592.html
-       depends on !BR2_TOOLCHAIN_USES_MUSL
-       select BR2_PACKAGE_LVM2_STANDARD_INSTALL
-       help
-         Install application library (liblvm2app).
-
-comment "lvm2 application library needs a glibc or uClibc toolchain"
-       depends on BR2_TOOLCHAIN_USES_MUSL
-
 endif
 
 comment "lvm2 needs a toolchain w/ threads, dynamic library"
index 84ec75530a4170859c52cca6dc1c00f08ef3a0b0..224dbf5d54706e4381a3027b8eefd4a251ad8082 100644 (file)
@@ -55,12 +55,6 @@ LVM2_INSTALL_STAGING_OPTS += install
 LVM2_INSTALL_TARGET_OPTS += install
 endif
 
-ifeq ($(BR2_PACKAGE_LVM2_APP_LIBRARY),y)
-LVM2_CONF_OPTS += --enable-applib
-else
-LVM2_CONF_OPTS += --disable-applib
-endif
-
 ifeq ($(BR2_INIT_SYSTEMD),y)
 LVM2_INSTALL_TARGET_OPTS += install_systemd_units install_systemd_generators
 endif
@@ -75,7 +69,6 @@ HOST_LVM2_CONF_OPTS = \
        --enable-pkgconfig \
        --disable-cmdlib \
        --disable-dmeventd \
-       --disable-applib \
        --disable-fsadm \
        --disable-readline \
        --disable-selinux
index efd3b619bf46e34e65016a3c02033c38f2c69f31..9d3eb240e6b0a375c1fee57b1686e00582243c44 100644 (file)
@@ -31,21 +31,6 @@ config BR2_PACKAGE_UDISKS
 
          http://www.freedesktop.org/wiki/Software/udisks
 
-if BR2_PACKAGE_UDISKS
-
-config BR2_PACKAGE_UDISKS_LVM2
-       bool "lvm2 support"
-       # The lvm app library can't compile against musl
-       depends on BR2_TOOLCHAIN_USES_GLIBC
-       select BR2_PACKAGE_LVM2_APP_LIBRARY
-       help
-         Enable LVM2 support
-
-comment "lvm2 support needs a glibc toolchain"
-       depends on !BR2_TOOLCHAIN_USES_GLIBC
-
-endif
-
 comment "udisks needs udev /dev management"
        depends on BR2_USE_MMU
        depends on !BR2_PACKAGE_HAS_UDEV
index af25c2b8e2249d004b2e584a2d7016a5cf08f438..9f7a02e10ccd98b053d2ccc10208f0082be3e977 100644 (file)
@@ -24,10 +24,6 @@ UDISKS_DEPENDENCIES = \
        sg3_utils \
        udev
 
-UDISKS_CONF_OPTS = --disable-remote-access --disable-man-pages
-
-ifeq ($(BR2_PACKAGE_UDISKS_LVM2),y)
-UDISKS_CONF_OPTS += --enable-lvm2
-endif
+UDISKS_CONF_OPTS = --disable-remote-access --disable-man-pages --disable-lvm2
 
 $(eval $(autotools-package))