gdb: properly set the gdb site in all cases
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 13 Apr 2013 04:09:10 +0000 (04:09 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 13 Apr 2013 18:12:39 +0000 (20:12 +0200)
Until now, the gdb site for AVR32 was adjusted only when GDB_VERSION
was not set, i.e only when the cross-gdb is *not* built. We should in
fact also set the site when the cross-gdb is built, so when
GDB_VERSION is defined through package/gdb/Config.in.host.

So, instead, we now have something like:

ifeq ($(GDB_VERSION),)
 # we define here a default version that is used when the cross-gdb is
 # not built and only the target gdb is selected.
endif

ifeq ($(GDB_VERSION),something-special)
GDB_SITE = some-special-site-for-some-special-gdb-version
endif

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gdb/gdb.mk

index 73ff7a465a5881cdc2640ab482d7891737e1ff26..398ef7bbe87d63df8b4308d3108c5745213ac578 100644 (file)
@@ -16,12 +16,15 @@ ifeq ($(BR2_bfin),y)
 GDB_VERSION = 6.6a
 else ifeq ($(BR2_avr32),y)
 GDB_VERSION = 6.7.1-avr32-2.1.5
-GDB_SITE    = ftp://www.at91.com/pub/buildroot/
 else
 GDB_VERSION = 7.5.1
 endif
 endif
 
+ifeq ($(GDB_VERSION),6.7.1-avr32-2.1.5)
+GDB_SITE = ftp://www.at91.com/pub/buildroot/
+endif
+
 GDB_SOURCE = gdb-$(GDB_VERSION).tar.bz2
 GDB_LICENSE = GPLv2+ LGPLv2+ GPLv3+ LGPLv3+
 GDB_LICENSE_FILES = COPYING COPYING.LIB COPYING3 COPYING3.LIB