package/x11r7/xkeyboard-config: needs a host python3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 21 Mar 2020 09:55:33 +0000 (10:55 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 21 Mar 2020 21:18:54 +0000 (22:18 +0100)
A host python3 is needed to run map-variants.py since version 2.29 and
https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/-/commit/57c745a9a373b4c9d272d00ff4f16dbcc6d3c48b

The script (with a backported patch) does not have stringent requirements
on python, so we may use a system python3 if present.

Fixes:
 - http://autobuild.buildroot.org/results/7c3cdecc2feed62d7e0bad0e790a8bacaaa34cb7

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/x11r7/xkeyboard-config/0001-fix-python3-support.patch [new file with mode: 0644]
package/x11r7/xkeyboard-config/xkeyboard-config.mk

diff --git a/package/x11r7/xkeyboard-config/0001-fix-python3-support.patch b/package/x11r7/xkeyboard-config/0001-fix-python3-support.patch
new file mode 100644 (file)
index 0000000..c9f8b59
--- /dev/null
@@ -0,0 +1,37 @@
+From c847c834cce190c5c835a454bfe548195da9fa53 Mon Sep 17 00:00:00 2001
+From: MilhouseVH <milhouseVH.github@nmacleod.com>
+Date: Sun, 16 Feb 2020 09:41:43 +0000
+Subject: [PATCH] fix python3 support
+
+https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/issues/197
+[Retrieved from:
+https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/-/commit/c847c834cce190c5c835a454bfe548195da9fa53]
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ rules/compat/map-variants.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/rules/compat/map-variants.py b/rules/compat/map-variants.py
+index ebbfec9..979ba43 100755
+--- a/rules/compat/map-variants.py
++++ b/rules/compat/map-variants.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python3
++#!/usr/bin/env python3
+ import argparse
+ import re
+@@ -12,8 +12,8 @@ class Layout(object):
+             assert variant is None
+             # parse a layout(variant) string
+             match = re.match(r'([^(]+)\(([^)]+)\)', layout)
+-            self.layout = match[1]
+-            self.variant = match[2]
++            self.layout = match.groups()[0]
++            self.variant = match.groups()[1]
+     def __str__(self):
+         if self.variant:
+-- 
+2.24.1
+
index fde5d058d84d20f3200ececcc68e5151081615a1..f2fc8565c390ca63d0610b7e029e785ca4f0f35f 100644 (file)
@@ -10,10 +10,14 @@ XKEYBOARD_CONFIG_SITE = https://www.x.org/releases/individual/data/xkeyboard-con
 XKEYBOARD_CONFIG_LICENSE = MIT
 XKEYBOARD_CONFIG_LICENSE_FILES = COPYING
 
+XKEYBOARD_CONFIG_DEPENDENCIES = \
+       $(BR2_PYTHON3_HOST_DEPENDENCY) \
+       host-gettext \
+       host-xapp_xkbcomp
+
 # xkeyboard-config.pc
 XKEYBOARD_CONFIG_INSTALL_STAGING = YES
 
 XKEYBOARD_CONFIG_CONF_OPTS = --disable-runtime-deps
-XKEYBOARD_CONFIG_DEPENDENCIES = host-gettext host-xapp_xkbcomp
 
 $(eval $(autotools-package))