python3: provide a PYTHON3_PATH
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 18 Feb 2014 20:40:02 +0000 (21:40 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 18 Feb 2014 22:29:34 +0000 (23:29 +0100)
The Python package infrastructure will need the Python 3 package to
provide a PYTHON3_PATH environment variable in order to build
third-party Python modules.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/python3/python3.mk

index ad9b9890951c0a952be01c4f06c0fca3bfa23164..1bf85004d0be4852d1ccbba36e36bf91afe90060 100644 (file)
@@ -147,5 +147,8 @@ endef
 
 HOST_PYTHON3_POST_INSTALL_HOOKS += HOST_PYTHON3_INSTALL_SYMLINK
 
+# Provided to other packages
+PYTHON3_PATH = $(TARGET_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/sysconfigdata/:$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages/
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))