pkg-generic: allow full URLs for <pkg>_EXTRA_DOWNLOADS
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Mar 2015 17:33:19 +0000 (19:33 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 30 Mar 2015 21:39:17 +0000 (23:39 +0200)
The current logic for <pkg>_EXTRA_DOWNLOADS assumes that it is a list
of files, all hosted at <pkg>_SITE. However, just like for
<pkg>_PATCH, it may be useful to specify <pkg>_EXTRA_DOWNLOADS entries
that are hosted on a different site than the package <pkg>_SITE.

This commit implements this, by re-using the same logic as the one
used for <pkg>_PATCH.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Romain Naour <romain.naour@openwide.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/pkg-generic.mk

index 3c868780bf664d87d59e41d545a61ede1352e9b6..22b3fb9616e31602769327904f572ea9f7af77d1 100644 (file)
@@ -81,7 +81,12 @@ ifeq ($(DL_MODE),DOWNLOAD)
        done
 endif
        $(if $($(PKG)_SOURCE),$(call DOWNLOAD,$($(PKG)_SITE:/=)/$($(PKG)_SOURCE)))
-       $(foreach p,$($(PKG)_EXTRA_DOWNLOADS),$(call DOWNLOAD,$($(PKG)_SITE:/=)/$(p))$(sep))
+       $(foreach p,$($(PKG)_EXTRA_DOWNLOADS),\
+               $(if $(findstring ://,$(p)),\
+                       $(call DOWNLOAD,$(p)),\
+                       $(call DOWNLOAD,$($(PKG)_SITE:/=)/$(p))\
+               )\
+       $(sep))
        $(foreach p,$($(PKG)_PATCH),\
                $(if $(findstring ://,$(p)),\
                        $(call DOWNLOAD,$(p)),\