lua-modules: fix dependencies with version of lua
authorFrancois Perrad <fperrad@gmail.com>
Fri, 16 Jan 2015 21:09:51 +0000 (22:09 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Feb 2015 14:53:42 +0000 (15:53 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/lbase64/Config.in
package/lrandom/lrandom.mk
package/lua-msgpack-native/Config.in
package/luaposix/Config.in
package/lunit/Config.in

index 48d3fdb3521107c440ef06c67d945885ac945eef..5ef91bf301c083b6fb88486dd74030c01b121cc7 100644 (file)
@@ -1,11 +1,12 @@
 config BR2_PACKAGE_LBASE64
        bool "lbase64"
        depends on BR2_PACKAGE_HAS_LUAINTERPRETER
-       depends on !BR2_PACKAGE_LUA_5_2
+       depends on BR2_PACKAGE_LUA_5_1 || BR2_PACKAGE_LUAJIT
        help
          A base64 library for Lua
 
          http://luaforge.net/projects/lbase64/
 
 comment "lbase64 needs a Lua 5.1 interpreter"
-       depends on BR2_PACKAGE_LUA_5_2
+       depends on !BR2_PACKAGE_LUA_5_1
+       depends on !BR2_PACKAGE_LUAJIT
index f0ee1e9c9d57dd142ca0695e6392324fe6bd5539..09b62c94a5e15d4a765da16d3fc47f528086d78a 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-ifeq ($(BR2_PACKAGE_LUA_5_2),y)
+ifeq ($(BR2_PACKAGE_LUA_5_2)$(BR2_PACKAGE_LUA_5_3),y)
 LRANDOM_VERSION = 20120430.52-1
 else
 LRANDOM_VERSION = 20120430.51-1
index c7b33731d012fba5e003e603beb446881789fd16..3837228fa0a5bae7303e865e2c856dedb4d9cf13 100644 (file)
@@ -1,7 +1,7 @@
 config BR2_PACKAGE_LUA_MSGPACK_NATIVE
        bool "lua-msgpack-native"
        depends on BR2_PACKAGE_HAS_LUAINTERPRETER
-       depends on !BR2_PACKAGE_LUA_5_2
+       depends on BR2_PACKAGE_LUA_5_1 || BR2_PACKAGE_LUAJIT
        help
          This is a native, C language implementation of msgpack
          (http://msgpack.org) library/protocol for Lua language
@@ -9,4 +9,5 @@ config BR2_PACKAGE_LUA_MSGPACK_NATIVE
          https://github.com/kengonakajima/lua-msgpack-native
 
 comment "lua-msgpack-native needs a Lua 5.1 interpreter"
-       depends on BR2_PACKAGE_LUA_5_2
+       depends on !BR2_PACKAGE_LUA_5_1
+       depends on !BR2_PACKAGE_LUAJIT
index a40c3f9bffef16bffab1572fec98fc22277d3a16..439dc42f56f638d0f14bf60aa91b2d6d36755734 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_LUAPOSIX
        bool "luaposix"
        depends on BR2_PACKAGE_HAS_LUAINTERPRETER
+       depends on !BR2_PACKAGE_LUA_5_3
        select BR2_PACKAGE_NCURSES
        select BR2_PACKAGE_LUABITOP if BR2_PACKAGE_LUA_5_1
        # LuaBitOp is already included in LuaJIT
@@ -13,3 +14,6 @@ config BR2_PACKAGE_LUAPOSIX
          APIs
 
          https://github.com/luaposix/luaposix
+
+comment "luaposix needs a Lua 5.1/5.2 interpreter"
+       depends on BR2_PACKAGE_LUA_5_3
index b3620efe263bf5ad8a7baed23c44675e86bb6c55..d6c2c6b157624d65cfef427271c50c5f478d5c0d 100644 (file)
@@ -1,10 +1,11 @@
 config BR2_PACKAGE_LUNIT
        bool "lunit"
-       depends on !BR2_PACKAGE_LUA_5_2
+       depends on BR2_PACKAGE_LUA_5_1 || BR2_PACKAGE_LUAJIT
        help
          A unit testing framework for Lua.
 
          http://www.mroth.net/lunit/
 
 comment "lunit needs a Lua 5.1 interpreter"
-       depends on BR2_PACKAGE_LUA_5_2
+       depends on !BR2_PACKAGE_LUA_5_1
+       depends on !BR2_PACKAGE_LUAJIT