zeromq: explicitly add -lstdc++ for static build
authorArnout Vandecappelle <arnout@mind.be>
Thu, 8 May 2014 23:24:27 +0000 (01:24 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 9 May 2014 14:31:42 +0000 (16:31 +0200)
Fixes http://autobuild.buildroot.net/results/7c552e514f8c13ba8cdd420dc5bbf5edac915a83

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/zeromq/zeromq.mk

index 7802916dfd75a2d0a79d28fa12435b767bed0a54..c1eee3ebeb4bf77476339e57d8e8ecb552a84e28 100644 (file)
@@ -12,9 +12,15 @@ ZEROMQ_LICENSE = LGPLv3+ with exceptions
 ZEROMQ_LICENSE_FILES = COPYING COPYING.LESSER
 ZEROMQ_AUTORECONF = YES
 
+# Only tools/curve_keygen.c needs this, but it doesn't hurt to pass it
+# for the rest of the build as well (which automatically includes stdc++).
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+       ZEROMQ_CONF_OPT += LIBS=-lstdc++
+endif
+
 ifeq ($(BR2_PACKAGE_ZEROMQ_PGM),y)
        ZEROMQ_DEPENDENCIES += host-pkgconf openpgm
-       ZEROMQ_CONF_OPT = --with-system-pgm
+       ZEROMQ_CONF_OPT += --with-system-pgm
 endif
 
 $(eval $(autotools-package))