package/Makefile.in: pass '-g0' explicitly if !BR2_ENABLE_DEBUG
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Tue, 25 May 2021 12:27:36 +0000 (14:27 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 25 May 2021 20:29:44 +0000 (22:29 +0200)
If BR2_ENABLE_DEBUG is not set, Buildroot did not pass any flag
to control debug level. This means that the build system of the package
itself would control it.

Instead, provide an explicit '-g0' (no debugging symbols) to get consistent
behavior across packages.

Suggested-by: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/Makefile.in

index f4028bc67cd7925f29c7d354203b8842db44d101..86db62ba5ba51f8f24bdc28d7480db5e812f4f9b 100644 (file)
@@ -136,6 +136,9 @@ endif
 ifeq ($(BR2_OPTIMIZE_FAST),y)
 TARGET_OPTIMIZATION = -Ofast
 endif
+ifeq ($(BR2_ENABLE_DEBUG),)
+TARGET_DEBUGGING = -g0
+endif
 ifeq ($(BR2_DEBUG_1),y)
 TARGET_DEBUGGING = -g1
 endif