systemd: convert to pkg-meson infra
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Tue, 15 May 2018 19:51:56 +0000 (21:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 30 May 2018 20:20:02 +0000 (22:20 +0200)
Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/systemd.mk

index 8f7a9fa93c6c521eb41aefaba0bb2a25e9b6bd77..82d0e1a027d014d006a0fdba8f4b8614053a77ab 100644 (file)
@@ -12,7 +12,6 @@ SYSTEMD_INSTALL_STAGING = YES
 SYSTEMD_DEPENDENCIES = \
        host-gperf \
        host-intltool \
-       host-meson \
        kmod \
        libcap \
        util-linux
@@ -26,10 +25,6 @@ SYSTEMD_DEPENDENCIES += busybox
 endif
 
 SYSTEMD_CONF_OPTS += \
-       --prefix=/usr \
-       --libdir='/usr/lib' \
-       --buildtype $(if $(BR2_ENABLE_DEBUG),debug,release) \
-       --cross-file $(HOST_DIR)/etc/meson/cross-compilation.conf \
        -Drootlibdir='/usr/lib' \
        -Dblkid=true \
        -Dman=false \
@@ -403,28 +398,7 @@ define SYSTEMD_INSTALL_INIT_SYSTEMD
        $(SYSTEMD_INSTALL_NETWORK_CONFS)
 endef
 
-SYSTEMD_NINJA_OPTS = $(if $(VERBOSE),-v) -j$(PARALLEL_JOBS)
+SYSTEMD_CONF_ENV = $(HOST_UTF8_LOCALE_ENV)
+SYSTEMD_NINJA_ENV = $(HOST_UTF8_LOCALE_ENV)
 
-SYSTEMD_ENV = $(TARGET_MAKE_ENV) $(HOST_UTF8_LOCALE_ENV)
-
-define SYSTEMD_CONFIGURE_CMDS
-       rm -rf $(@D)/build
-       mkdir -p $(@D)/build
-       $(SYSTEMD_ENV) meson $(SYSTEMD_CONF_OPTS) $(@D) $(@D)/build
-endef
-
-define SYSTEMD_BUILD_CMDS
-       $(SYSTEMD_ENV) ninja $(SYSTEMD_NINJA_OPTS) -C $(@D)/build
-endef
-
-define SYSTEMD_INSTALL_TARGET_CMDS
-       $(SYSTEMD_ENV) DESTDIR=$(TARGET_DIR) ninja $(SYSTEMD_NINJA_OPTS) \
-               -C $(@D)/build install
-endef
-
-define SYSTEMD_INSTALL_STAGING_CMDS
-       $(SYSTEMD_ENV) DESTDIR=$(STAGING_DIR) ninja $(SYSTEMD_NINJA_OPTS) \
-               -C $(@D)/build install
-endef
-
-$(eval $(generic-package))
+$(eval $(meson-package))