qhull: new package
authorDavide Viti <d.viti@infosolution.it>
Fri, 18 Apr 2014 22:30:01 +0000 (00:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Apr 2014 17:04:01 +0000 (19:04 +0200)
Signed-off-by: Davide Viti <d.viti@infosolution.it>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/qhull/Config.in [new file with mode: 0644]
package/qhull/qhull.mk [new file with mode: 0644]

index 748d28e1a77a1caefc9191d954a401202c012e03..44c35eaa676dd7e9d315ec74d47c0b9e21b867f3 100644 (file)
@@ -820,6 +820,7 @@ source "package/p11-kit/Config.in"
 source "package/poco/Config.in"
 source "package/protobuf/Config.in"
 source "package/protobuf-c/Config.in"
+source "package/qhull/Config.in"
 source "package/schifra/Config.in"
 source "package/startup-notification/Config.in"
 source "package/tz/Config.in"
diff --git a/package/qhull/Config.in b/package/qhull/Config.in
new file mode 100644 (file)
index 0000000..4f172bd
--- /dev/null
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_QHULL
+       bool "qhull"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on !BR2_PREFER_STATIC_LIB
+       help
+         Qhull computes the convex hull, Delaunay triangulation,
+         Voronoi diagram, halfspace intersection about a point,
+         furthest-site Delaunay triangulation, and furthest-site
+         Voronoi diagram. The source code runs in 2-d, 3-d, 4-d, and
+         higher dimensions. Qhull implements the Quickhull algorithm
+         for computing the convex hull. It handles roundoff errors
+         from floating point arithmetic. It computes volumes, surface
+         areas, and approximations to the convex hull.
+
+         http://www.qhull.org
+
+comment "qhull needs a toolchain w/ C++, dynamic library"
+       depends on !BR2_INSTALL_LIBSTDCPP
+       depends on BR2_PREFER_STATIC_LIB
diff --git a/package/qhull/qhull.mk b/package/qhull/qhull.mk
new file mode 100644 (file)
index 0000000..f2bc771
--- /dev/null
@@ -0,0 +1,14 @@
+###############################################################################
+#
+# qhull
+#
+###############################################################################
+
+QHULL_VERSION = 60d55819729d7b49391dde0271e15a56c70992b9
+QHULL_SITE = git://gitorious.org/qhull/qhull.git
+QHULL_INSTALL_STAGING = YES
+QHULL_LICENSE = BSD-Style
+QHULL_LICENSE_FILES = COPYING.txt
+QHULL_CONF_OPT = -DCMAKE_BUILD_TYPE=Release
+
+$(eval $(cmake-package))