Prevent patch commands from accessing source control
authorDanomi Mocelopolis <d_mo1234@yahoo.com>
Sat, 26 Nov 2011 20:56:25 +0000 (21:56 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 26 Nov 2011 20:56:25 +0000 (21:56 +0100)
Closes #4357

Add -g0 option to patch to ensure it doesn't try to access source control.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
boot/grub/grub.mk
support/scripts/apply-patches.sh

diff --git a/CHANGES b/CHANGES
index b8bb451af6c5e7823e3ed15b9360a8cd796e26a1..3173fe6dddff7cf0fb2ce4cab9963cc166fd567e 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -11,6 +11,7 @@
 
        Issues resolved (http://bugs.uclibc.org):
 
+       #4357: Prevent patch commands from accessing source control
        #4369: Fix permissions on untared lsof archive
 
 2011.11-rc2, Released November 18th, 2011:
index fbff867112f5435ecf581f8819a315d66832f019..1b5ca0dd2172d9dd8ce40266125da5a9f7726963 100644 (file)
@@ -41,7 +41,7 @@ GRUB_CONFIG-$(BR2_TARGET_GRUB_w89c840) += --enable-w89c840
 define GRUB_DEBIAN_PATCHES
        # Apply the patches from the Debian patch
        (cd $(@D) ; for f in `cat debian/patches/00list | grep -v ^#` ; do \
-               cat debian/patches/$$f | patch -p1 ; \
+               cat debian/patches/$$f | patch -g0 -p1 ; \
        done)
 endef
 
index 76cb9f75331193098dddd54521fd0265a65595b9..1aef47ebf78b725294a50c02c51c4b1bbfa8e358 100755 (executable)
@@ -21,7 +21,7 @@ if [ ! -d "${patchdir}" ] ; then
 fi
     
 for i in `cd ${patchdir}; ls -d ${patchpattern} 2> /dev/null` ; do 
-    apply="patch -p1 -E -d"
+    apply="patch -g0 -p1 -E -d"
     uncomp_parm=""
     if [ -d "${patchdir}/$i" ] ; then
        type="directory overlay"