pigz: new package
authorAlfredo Alvarez Fernandez <alfredo.alvarez_fernandez@nokia.com>
Wed, 4 Jul 2018 07:07:36 +0000 (09:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 4 Jul 2018 20:28:09 +0000 (22:28 +0200)
A parallel implementation of gzip for modern
multi-processor, multi-core machines.

Signed-off-by: Alfredo Alvarez Fernandez <alfredo.alvarez_fernandez@nokia.com>
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
[Thomas: add entry to DEVELOPERS file, add hash for license file.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/pigz/Config.in [new file with mode: 0644]
package/pigz/pigz.hash [new file with mode: 0644]
package/pigz/pigz.mk [new file with mode: 0644]

index 803d248b4f8cafeff4bfedffa15b6d37d60b5f22..1fa0020dbbea87ae840615b364e6134ebcee1801 100644 (file)
@@ -1914,6 +1914,7 @@ F:        package/civetweb/
 N:     Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
 F:     docs/manual/
 F:     package/opkg-utils/
+F:     package/pigz/
 F:     support/scripts/size-stats
 F:     utils/size-stats-compare
 F:     toolchain/
index e94a6a8c12c4e0a652ed3cee17bda19b8ff89fe0..20fe5ad8ff9f6ce4506c1afe7897c64e81f40ff5 100644 (file)
@@ -70,6 +70,7 @@ menu "Compressors and decompressors"
        source "package/lzip/Config.in"
        source "package/lzop/Config.in"
        source "package/p7zip/Config.in"
+       source "package/pigz/Config.in"
        source "package/pixz/Config.in"
        source "package/unrar/Config.in"
        source "package/unzip/Config.in"
diff --git a/package/pigz/Config.in b/package/pigz/Config.in
new file mode 100644 (file)
index 0000000..af22906
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_PIGZ
+       bool "pigz"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_ZLIB
+       help
+         pigz, which stands for parallel implementation of gzip, is a
+         fully functional replacement for gzip that exploits multiple
+         processors and multiple cores to the hilt when compressing
+         data.
+
+         http://www.zlib.net/pigz/
+
+comment "pigz needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/pigz/pigz.hash b/package/pigz/pigz.hash
new file mode 100644 (file)
index 0000000..850e94f
--- /dev/null
@@ -0,0 +1,3 @@
+# From https://zlib.net/pigz/
+sha256  a4f816222a7b4269bd232680590b579ccc72591f1bb5adafcd7208ca77e14f73  pigz-2.4.tar.gz
+sha256 dc8f78258cdb4478b5922f4c00eb63d3cbac06c171dc829648fd414bb0cf4493  README
diff --git a/package/pigz/pigz.mk b/package/pigz/pigz.mk
new file mode 100644 (file)
index 0000000..82f3049
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# pigz
+#
+################################################################################
+
+PIGZ_VERSION = 2.4
+PIGZ_SITE = http://www.zlib.net/pigz
+PIGZ_DEPENDENCIES = zlib
+PIGZ_LICENSE = Zlib
+PIGZ_LICENSE_FILES = README
+
+define PIGZ_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define PIGZ_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/pigz $(TARGET_DIR)/usr/bin/pigz
+endef
+
+$(eval $(generic-package))