Makefile: system.mk rootfs modifications should be done before target-finalize
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 9 Jan 2013 12:20:05 +0000 (13:20 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 9 Jan 2013 12:20:05 +0000 (13:20 +0100)
So they don't override E.G. changes done in post build scripts
(E.G. password settings).

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 4b094376f52c650a4b1daa5aa4c3310f70900917..074674a165a5e1d9e378a71bd9cec9c6c5cc9e90 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -322,6 +322,7 @@ include package/*/*.mk
 
 include boot/common.mk
 include linux/linux.mk
+include system/system.mk
 
 TARGETS+=target-finalize
 
@@ -335,7 +336,6 @@ TARGETS+=target-generatelocales
 endif
 endif
 
-include system/system.mk
 include fs/common.mk
 
 TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))