librtlsdr: new package
authorJason Pruitt <jrspruitt@gmail.com>
Tue, 1 Jul 2014 21:00:25 +0000 (23:00 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 8 Jul 2014 15:28:03 +0000 (17:28 +0200)
librtlsdr is a library and software for using a Realtek RTL2832U based
DVB-T dongle as a cheap SDR.

[Thomas: change license to GPLv2+, reword help text for the detach
driver option.]

Signed-off-by: Jason Pruitt <jrspruitt@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/librtlsdr/Config.in [new file with mode: 0644]
package/librtlsdr/librtlsdr.mk [new file with mode: 0644]

index 8e1c3913cba07b46f11d19ed0c5cd464be8f14b8..f30c25f62f018568deca1f3db471536e6181881e 100644 (file)
@@ -649,6 +649,7 @@ menu "Hardware handling"
        source "package/libnfc/Config.in"
        source "package/libqmi/Config.in"
        source "package/libraw1394/Config.in"
+       source "package/librtlsdr/Config.in"
        source "package/libserial/Config.in"
        source "package/libsoc/Config.in"
        source "package/libusb/Config.in"
diff --git a/package/librtlsdr/Config.in b/package/librtlsdr/Config.in
new file mode 100644 (file)
index 0000000..1e217bc
--- /dev/null
@@ -0,0 +1,24 @@
+config BR2_PACKAGE_LIBRTLSDR
+       bool "librtlsdr"
+       select BR2_PACKAGE_LIBUSB
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         Library and command line programs for accessing
+         RTL2832U SDR dongles.
+
+         http://sdr.osmocom.org/trac/wiki/rtl-sdr/
+
+if BR2_PACKAGE_LIBRTLSDR
+
+config BR2_PACKAGE_LIBRTLSDR_DETACH_DRIVER
+       bool "Detach kernel driver"
+       default y
+       help
+         Enable this option if you would like librtlsdr to
+         automatically detach any kernel driver associated to the
+         RTL2832U USB device on startup if one is loaded.
+
+endif
+
+comment "librtlsdr needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/librtlsdr/librtlsdr.mk b/package/librtlsdr/librtlsdr.mk
new file mode 100644 (file)
index 0000000..985614a
--- /dev/null
@@ -0,0 +1,22 @@
+##########################################################################
+#
+# librtlsdr
+#
+##########################################################################
+
+LIBRTLSDR_VERSION = v0.5.3
+LIBRTLSDR_SITE = $(call github,steve-m,librtlsdr,$(LIBRTLSDR_VERSION))
+LIBRTLSDR_LICENSE = GPLv2+
+LIBRTLSDR_LICENSE_FILES = COPYING
+LIBRTLSDR_INSTALL_STAGING = YES
+LIBRTLSDR_DEPENDENCIES = libusb
+
+ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
+LIBRTLSDR_CONF_OPT += -DINSTALL_UDEV_RULES=ON
+endif
+
+ifeq ($(BR2_PACKAGE_LIBRTLSDR_DETACH_DRIVER),y)
+LIBRTLSDR_CONF_OPT += -DDETACH_KERNEL_DRIVER=1
+endif
+
+$(eval $(cmake-package))