package/c-icap: add optional support for pcre
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 May 2017 21:41:19 +0000 (23:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 May 2017 13:39:23 +0000 (15:39 +0200)
Support for pcre was added in 2014:
https://sourceforge.net/p/c-icap/code/1135/#diff-4

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/c-icap/c-icap.mk

index 2d8b30920bba646585f9ed701a55947ca17d0f0f..750b231c7c39d89cafa98780dcdc041c3c8ca685 100644 (file)
@@ -48,6 +48,13 @@ else
 C_ICAP_CONF_OPTS += --without-ldap
 endif
 
+ifeq ($(BR2_PACKAGE_PCRE),y)
+C_ICAP_CONF_OPTS += --with-pcre
+C_ICAP_DEPENDENCIES += pcre
+else
+C_ICAP_CONF_OPTS += --without-pcre
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 C_ICAP_CONF_OPTS += --with-zlib
 C_ICAP_DEPENDENCIES += zlib