package/nginx: add stream_set_module support
authorAdam Duskett <aduskett@gmail.com>
Wed, 30 Jun 2021 17:36:57 +0000 (10:36 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 20 Jul 2021 21:51:13 +0000 (23:51 +0200)
This is a new module in 1.20

Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nginx/Config.in
package/nginx/nginx.mk

index 6ae790a949cba9a876ad2fa7ef24e35858cbe2e5..1200b2bf4c1d7c9e15677ee58f46d4652bd8cab7 100644 (file)
@@ -339,6 +339,12 @@ config BR2_PACKAGE_NGINX_STREAM_REALIP_MODULE
        help
          Enable ngx_stream_realip_module
 
+config BR2_PACKAGE_NGINX_STREAM_SET_MODULE
+       bool "ngx_stream_set_module"
+       default y
+       help
+         Enable ngx_stream_set_module
+
 config BR2_PACKAGE_NGINX_STREAM_SSL_MODULE
        bool "ngx_stream_ssl_module"
        select BR2_PACKAGE_OPENSSL
index 36515e67cc4e10c38730ddee1796d29ea08ac5cc..1f996cc613183e014af19d10552a8ba9ce50574b 100644 (file)
@@ -232,6 +232,10 @@ ifeq ($(BR2_PACKAGE_NGINX_STREAM_REALIP_MODULE),y)
 NGINX_CONF_OPTS += --with-stream_realip_module
 endif
 
+ifeq ($(BR2_PACKAGE_NGINX_STREAM_SET_MODULE),)
+NGINX_CONF_OPTS += --without-stream_set_module
+endif
+
 ifeq ($(BR2_PACKAGE_NGINX_STREAM_SSL_MODULE),y)
 NGINX_DEPENDENCIES += openssl
 NGINX_CONF_OPTS += --with-stream_ssl_module