package/libtomcrypt: compile with -fPIC to enable linking to dynamic libraries/exectu...
authorPeter Seiderer <ps.report@gmx.net>
Sun, 2 May 2021 10:50:38 +0000 (12:50 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 4 May 2021 20:14:37 +0000 (22:14 +0200)
Fixes:

  .../x86_64-buildroot-linux-gnu/bin/ld: .../host/x86_64-buildroot-linux-gnu/sysroot/usr/lib/libtomcrypt.a(md5.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC

when building a shared library that links with libtomcrypt. Our only
internal user dropbear doesn't do this, so there are no autobuilder
failures.

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libtomcrypt/libtomcrypt.mk

index fccd4b051c771e6e057f35f0642dd4c70611367f..35886057d48e34b4f501a89936355c9ccfedb39a 100644 (file)
@@ -19,6 +19,10 @@ LIBTOMCRYPT_IGNORE_CVES += CVE-2019-17362
 
 LIBTOMCRYPT_CFLAGS = -I./src/headers $(TARGET_CFLAGS) -DLTC_SOURCE -DLTM_DESC
 
+ifeq ($(BR2_STATIC_LIBS),)
+LIBTOMCRYPT_CFLAGS += -fPIC
+endif
+
 define LIBTOMCRYPT_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) CFLAGS="$(LIBTOMCRYPT_CFLAGS)"
 endef