erlang: always use Buildroot's zlib
authorFrank Hunleth <fhunleth@troodon-software.com>
Fri, 12 Oct 2018 14:11:49 +0000 (10:11 -0400)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 14 Oct 2018 20:47:31 +0000 (22:47 +0200)
While Erlang includes a version of zlib, it's intended for Windows and
there's an expectation that non-Windows platforms provide it. It's also
not as regularly updated as the one in Buildroot. This change makes
Erlang always use a Buildroot-provided zlib.

Fixes this compile error:

 CC /home/buildroot/autobuild/run/instance-0/output/build/erlang-21.0/erts/emulator/zlib/obj/x86_64-buildroot-linux-musl/opt/adler32.o
In file included from zlib/adler32.c:11:0:
zlib/zutil.h:172:39: error: "_LFS64_LARGEFILE" is not defined [-Werror=undef]
     (!defined(_LARGEFILE64_SOURCE) || _LFS64_LARGEFILE-0 == 0)
                                       ^~~~~~~~~~~~~~~~

See http://autobuild.buildroot.net/results/fc633f80c7c36a90e641487f5a888fbb767c2a54/.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/erlang/Config.in
package/erlang/erlang.mk

index 75ba17086a59cd18cc4b65875fb237a73e2d47d7..ab87eab6fff417d888737cc89c3714d73a7b5252 100644 (file)
@@ -23,6 +23,7 @@ config BR2_PACKAGE_ERLANG
        depends on !BR2_STATIC_LIBS
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_PACKAGE_ERLANG_ARCH_SUPPORTS
+       select BR2_PACKAGE_ZLIB
        help
          Erlang is a programming language used to build massively
          scalable soft real-time systems with requirements on high
index 2ac903ffeae7a8e28a57eac71892df4974f0147b..ca0aa0b770560c538bfbca4d94639d354ba03fb4 100644 (file)
@@ -64,10 +64,9 @@ else
 ERLANG_CONF_OPTS += --without-odbc
 endif
 
-ifeq ($(BR2_PACKAGE_ZLIB),y)
+# Always use Buildroot's zlib
 ERLANG_CONF_OPTS += --enable-shared-zlib
 ERLANG_DEPENDENCIES += zlib
-endif
 
 # Remove source, example, gs and wx files from staging and target.
 ERLANG_REMOVE_PACKAGES = gs wx