u-boot: add option to specify config fragments
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Oct 2017 13:46:33 +0000 (15:46 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Fri, 6 Oct 2017 16:44:18 +0000 (18:44 +0200)
U-Boot nowadays also uses kconfig, so we can handle config fragments like we
do for barebox/busybox/linux.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
boot/uboot/Config.in
boot/uboot/uboot.mk

index 84b7fb42eeed8797d7cba6c5ec7581656c70da39..8215912339ba4131d3fa38776845b8a0e09e6157 100644 (file)
@@ -129,6 +129,12 @@ config BR2_TARGET_UBOOT_CUSTOM_CONFIG_FILE
        depends on BR2_TARGET_UBOOT_USE_CUSTOM_CONFIG
        help
          Path to the U-Boot configuration file.
+
+config BR2_TARGET_UBOOT_CONFIG_FRAGMENT_FILES
+       string "Additional configuration fragment files"
+       help
+         A space-separated list of configuration fragment files,
+         that will be merged to the main U-Boot configuration file.
 endif
 
 config BR2_TARGET_UBOOT_NEEDS_DTC
index 14a8cc949a335e9e44aeeb5c3d746d061ad4e9fc..fdacf168561dfef0d818882132c4b7a76c7858d6 100644 (file)
@@ -196,6 +196,7 @@ else ifeq ($(BR2_TARGET_UBOOT_USE_CUSTOM_CONFIG),y)
 UBOOT_KCONFIG_FILE = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_CONFIG_FILE))
 endif # BR2_TARGET_UBOOT_USE_DEFCONFIG
 
+UBOOT_KCONFIG_FRAGMENT_FILES = $(call qstrip,$(BR2_TARGET_UBOOT_CONFIG_FRAGMENT_FILES))
 UBOOT_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
 UBOOT_KCONFIG_OPTS = $(UBOOT_MAKE_OPTS)
 define UBOOT_HELP_CMDS