imx-vpu: bump to version 5.4.32
authorGary Bisson <gary.bisson@boundarydevices.com>
Wed, 16 Mar 2016 14:56:49 +0000 (15:56 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 18 Mar 2016 22:22:35 +0000 (23:22 +0100)
Changelog:
- Support AVcVuiInfo for Decoder through DecInitialInfo or DecOutputInfo
- Clear structure iram IOGetIramBase() fails to set them to avoid
using uninitialized variables.

This patch is based on the Yocto equivalent:
https://github.com/Freescale/meta-fsl-arm/commit/be030922

This package has been implicitely tested through gstreamer as the
plugins rely on it for vpu decoding:
 # gst-launch-0.10 playbin uri=file:///root/tears_of_steel_1080p.webm
 # gst-launch-1.0 playbin uri=file:///root/tears_of_steel_1080p.webm
 # gst-launch-1.0 filesrc location=/root/tears_of_steel_1080p.webm ! \
   matroskademux ! imxvpudec ! imxipuvideosink

Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/freescale-imx/imx-vpu/imx-vpu.hash
package/freescale-imx/imx-vpu/imx-vpu.mk

index 3fdd092e1699c6db50c96022c93a254232896541..c828c2b09b7937dd6bfdd3ccd6d9763cc7c983e2 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed
-sha256 a266ab317fbd866541eae506d68983bcd361f49d1162a66bb34cb8088ceec88c imx-vpu-5.4.31.bin
+sha256 f11b91dcdb84bfefd3c88f10a9c1c1bc3420e4bbaadc38b9280fb52f7769eca8  imx-vpu-5.4.32.bin
index 571cc402354c73c23ea00ce498a87fb70c24821c..949fefa4e24e6e819d2ba20d2cbe8d101dbf771a 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-IMX_VPU_VERSION = 5.4.31
+IMX_VPU_VERSION = 5.4.32
 IMX_VPU_SITE = $(FREESCALE_IMX_SITE)
 IMX_VPU_SOURCE = imx-vpu-$(IMX_VPU_VERSION).bin