toolchain: add user defined target LDFLAGS options
authorBaruch Siach <baruch@tkos.co.il>
Thu, 23 Jun 2011 09:21:21 +0000 (12:21 +0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 25 Jul 2011 06:31:15 +0000 (08:31 +0200)
Allow the user to specify additional options for the target LDFLAGS.

I use this to pass the -te500v2 option to the linker, when using the
CodeSourcery toolchain for PowerPC. This chooses the correct CRT for e500 hard
float. Otherwise I get errors like

undefined reference to `_save32gpr_31'
undefined reference to `_rest32gpr_31_x'

at final link time.

[Peter: fixup, use qstrip]
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.in
toolchain/toolchain-common.in

index 8e9637ce8d4d00135358e4e89cd29184cfcfd537..c3af5d3ea531ab08bb1d6f0b62b9f76036dbb8f2 100644 (file)
@@ -77,6 +77,7 @@ TARGET_CFLAGS+=-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
 endif
 
 TARGET_CXXFLAGS=$(TARGET_CFLAGS)
+TARGET_LDFLAGS=$(call qstrip,$(BR2_TARGET_LDFLAGS))
 
 ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_CTNG),y)
 TARGET_CROSS=$(HOST_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-
index 4a2f3795b1fff3108569e485d96da4ecb8579b52..bbb7be627e3ca2cc34dd52c1976c99fae2649af3 100644 (file)
@@ -96,3 +96,8 @@ config BR2_TARGET_OPTIMIZATION
        help
          Optimizations to use when building for the target host.
          NOTE: gcc optimization level is defined in build options.
+
+config BR2_TARGET_LDFLAGS
+       string "Target linker options"
+       help
+         Extra options to pass to the linker when buiding for the target.