package/wvstreams: add argp-standalone as optional dependency
authorRomain Naour <romain.naour@openwide.fr>
Fri, 1 May 2015 16:44:46 +0000 (18:44 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 May 2015 21:03:02 +0000 (23:03 +0200)
This ensures the build reproducibility.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wvstreams/wvstreams.mk

index bc7c5d445a914cafddb04b73d892478d17fdd456..4d344e28340f34daa409a9e6e1c13726921ebcd5 100644 (file)
@@ -32,6 +32,12 @@ ifneq ($(BR2_STATIC_LIBS),y)
 WVSTREAMS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -fPIC"
 endif
 
+# wvstreams uses argp.h which can be provided by the argp-standalone
+# package
+ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
+WVSTREAMS_DEPENDENCIES += argp-standalone
+endif
+
 ifeq ($(BR2_PACKAGE_DBUS),y)
 WVSTREAMS_DEPENDENCIES += dbus
 WVSTREAMS_CONF_OPTS += --with-dbus