lvm2: ensured TARGET_AR is used during build
authorJordan Yelloz <jordan@yelloz.me>
Mon, 12 Dec 2016 18:13:54 +0000 (10:13 -0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Dec 2016 15:05:17 +0000 (16:05 +0100)
The same way TARGET_CC was not being used during the build, TARGET_AR
was not used either. Now TARGET_CONFIGURE_OPTS is injected into
LVM2_MAKE_ENV which should include all the toolchain substitutions.

Signed-off-by: Jordan Yelloz <jordan@yelloz.me>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lvm2/lvm2.mk

index ae9581caaef4cbcacfcf118ef59fcab71ff86f8c..a2d484bc250a38ad22e06386b2d3cda84291d8ba 100644 (file)
@@ -20,8 +20,8 @@ LVM2_CONF_OPTS += \
        --enable-dmeventd
 
 # LVM2 uses autoconf, but not automake, and the build system does not
-# take into account the CC passed at configure time.
-LVM2_MAKE_ENV = CC="$(TARGET_CC)"
+# take into account the toolchain passed at configure time.
+LVM2_MAKE_ENV = $(TARGET_CONFIGURE_OPTS)
 
 ifeq ($(BR2_PACKAGE_READLINE),y)
 LVM2_DEPENDENCIES += readline