package/qemu: disable vnc optional support for the host variant
authorRomain Naour <romain.naour@gmail.com>
Mon, 6 Apr 2020 14:21:57 +0000 (16:21 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 18:18:08 +0000 (20:18 +0200)
The vnc support is enabled by default and the build system
will try to detect automatically some external libraries
installed on the host for vnc-png, vnc-jpeg and vnc-sasl.

$ ldd output/host/bin/qemu-system-aarch64
[...]
libpng16.so.16 => /lib64/libpng16.so.16
or
libpng16.so.16 => output/host/lib/libpng16.so.16
if host-libpng is built before host-qemu.

Disable explicitely thoses options to improve the build
reproducibility.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/qemu/qemu.mk

index 3c3b098a5be9a86041fde48d792e8cce5476da08..b8904ffe186ceb842b6ed776acdbb40a2b7a1ccb 100644 (file)
@@ -304,6 +304,9 @@ define HOST_QEMU_CONFIGURE_CMDS
                --extra-ldflags="$(HOST_LDFLAGS)" \
                --python=$(HOST_DIR)/bin/python3 \
                --disable-libssh \
+               --disable-vnc-jpeg \
+               --disable-vnc-png \
+               --disable-vnc-sasl \
                $(HOST_QEMU_OPTS)
 endef