package/wireshark: add libkrb5 optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 3 Nov 2018 14:08:10 +0000 (15:08 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 3 Nov 2018 14:56:57 +0000 (15:56 +0100)
Specify the path to found libkrb5 as this is done for other options

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wireshark/wireshark.mk

index 421338f0f8b72d603169f01627476fbf720ae995..357ef10c9f80528d6e6919e918ba12e21dabb586 100644 (file)
@@ -19,7 +19,6 @@ WIRESHARK_AUTORECONF = YES
 # wireshark adds -I$includedir to CFLAGS, causing host/target headers mixup.
 # Work around it by pointing includedir at staging
 WIRESHARK_CONF_OPTS = \
-       --without-krb5 \
        --enable-static=no \
        --with-libsmi=no \
        --with-pcap=$(STAGING_DIR)/usr \
@@ -84,6 +83,13 @@ else
 WIRESHARK_CONF_OPTS += --with-gcrypt=no
 endif
 
+ifeq ($(BR2_PACKAGE_LIBKRB5),y)
+WIRESHARK_CONF_OPTS += --with-krb5=$(STAGING_DIR)/usr
+WIRESHARK_DEPENDENCIES += libkrb5
+else
+WIRESHARK_CONF_OPTS += --without-krb5
+endif
+
 ifeq ($(BR2_PACKAGE_LIBNL),y)
 WIRESHARK_CONF_OPTS += --with-libnl
 WIRESHARK_DEPENDENCIES += libnl