Makefile.autotools.in: fixup .la files in all lib dirs
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 18 Jan 2010 13:53:06 +0000 (14:53 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 18 Jan 2010 13:53:06 +0000 (14:53 +0100)
Sometimes usr/lib32 or usr/lib64 is used instead of usr/lib, so search
those for .la files as well.

Fixes .la fixup for beecrypt on x86-64.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.autotools.in

index f0f189f90e0c096e36d2369d577ce4e7e9305a64..7114bbab3995ff50d52ec38cfffee41a94293765 100644 (file)
@@ -201,7 +201,7 @@ endif
 ifndef $(2)_INSTALL_STAGING_CMDS
 define $(2)_INSTALL_STAGING_CMDS
        $$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) $$($$(PKG)_INSTALL_STAGING_OPT) -C $$($$(PKG)_SRCDIR)
-       for i in $$$$(find $(STAGING_DIR)/usr/lib/ -name "*.la"); do \
+       for i in $$$$(find $(STAGING_DIR)/usr/lib* -name "*.la"); do \
                cp $$$$i $$$$i~; \
                $$(SED) "s:\(['= ]\)/usr:\\1$(STAGING_DIR)/usr:g" $$$$i; \
        done