vsftpd: add empty directory /usr/share/empty
authorStephan Hoffmann <sho@relinux.de>
Mon, 21 Jan 2013 08:21:29 +0000 (08:21 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 21 Jan 2013 22:58:18 +0000 (23:58 +0100)
Vsftpd needs an empty directory where it can chroot.
If /usr/share/empty isn't present it refuses to work in the default
configuration.

Signed-off-by: Stephan Hoffmann <sho@relinux.de>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/vsftpd/vsftpd.mk

index a075e82629cca558b8105e9ed1617981139f0802..36f264589380547cabdede314a2e2ec0b183fa5f 100644 (file)
@@ -47,6 +47,7 @@ define VSFTPD_INSTALL_TARGET_CMDS
        test -f $(TARGET_DIR)/etc/vsftpd.conf || \
                $(INSTALL) -D -m 644 $(@D)/vsftpd.conf \
                        $(TARGET_DIR)/etc/vsftpd.conf
+       install -d -m 700 $(TARGET_DIR)/usr/share/empty
 endef
 
 define VSFTPD_UNINSTALL_TARGET_CMDS